summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-22 23:58:36 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-22 23:58:36 +0000
commitb3b8fc37332a7215cc752c4c32e4670733bd6428 (patch)
tree7acc194bdee28acbb692f928d0810882b5ebc60a /kde-misc
parentBugfix version bump for 5.x (diff)
downloadgentoo-2-b3b8fc37332a7215cc752c4c32e4670733bd6428.tar.gz
gentoo-2-b3b8fc37332a7215cc752c4c32e4670733bd6428.tar.bz2
gentoo-2-b3b8fc37332a7215cc752c4c32e4670733bd6428.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/semantik/ChangeLog8
-rw-r--r--kde-misc/semantik/files/semantik-0.9.0-wscript_ldconfig.patch17
-rw-r--r--kde-misc/semantik/semantik-0.9.0.ebuild47
3 files changed, 71 insertions, 1 deletions
diff --git a/kde-misc/semantik/ChangeLog b/kde-misc/semantik/ChangeLog
index d96547f0eacb..2a3558aa2c33 100644
--- a/kde-misc/semantik/ChangeLog
+++ b/kde-misc/semantik/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/semantik
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/semantik/ChangeLog,v 1.11 2013/09/10 14:44:42 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/semantik/ChangeLog,v 1.12 2013/12/22 23:58:36 mrueg Exp $
+
+*semantik-0.9.0 (22 Dec 2013)
+
+ 22 Dec 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/semantik-0.9.0-wscript_ldconfig.patch, +semantik-0.9.0.ebuild:
+ Version bump.
10 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -semantik-0.8.3.ebuild:
Cleanup old.
diff --git a/kde-misc/semantik/files/semantik-0.9.0-wscript_ldconfig.patch b/kde-misc/semantik/files/semantik-0.9.0-wscript_ldconfig.patch
new file mode 100644
index 000000000000..94ecd95c9a7e
--- /dev/null
+++ b/kde-misc/semantik/files/semantik-0.9.0-wscript_ldconfig.patch
@@ -0,0 +1,17 @@
+--- wscript.old 2013-12-23 00:56:28.623714186 +0100
++++ wscript 2013-12-23 00:56:39.592714596 +0100
+@@ -226,14 +226,6 @@
+ opt.add_option('--noldconfig', action='store_true', default=False, help='do not run lconfig when installing')
+
+ def post_build(bld):
+- if bld.cmd == 'install':
+- if not Options.options.noldconfig:
+- try: bld.exec_command('/sbin/ldconfig 2> /dev/null')
+- except Exception: pass
+- if not Options.options.nomimes:
+- try: bld.exec_command('update-mime-database %s' % os.path.split(bld.env.MIME_DIR)[0])
+- except Exception: pass
+-
+ if Options.options.exe:
+ #os.popen('export LD_LIBRARY_PATH=out/default/:$LD_LIBRARY_PATH; PATH=plugins:$PATH out/default/src/semantik')
+ bld.exec_command('LD_LIBRARY_PATH=build/:$LD_LIBRARY_PATH build/src/semantik --style plastique', stdout=None, stderr=None)
diff --git a/kde-misc/semantik/semantik-0.9.0.ebuild b/kde-misc/semantik/semantik-0.9.0.ebuild
new file mode 100644
index 000000000000..bd6ff0792258
--- /dev/null
+++ b/kde-misc/semantik/semantik-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/semantik/semantik-0.9.0.ebuild,v 1.1 2013/12/22 23:58:36 mrueg Exp $
+
+EAPI=5
+
+CMAKE_REQUIRED="never"
+NO_WAF_LIBDIR="true"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="xml"
+inherit python-single-r1 flag-o-matic kde4-base multilib toolchain-funcs waf-utils
+
+DESCRIPTION="Mindmapping-like tool for document generation."
+HOMEPAGE="http://freehackers.org/~tnagy/semantik.html"
+SRC_URI="https://semantik.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${DEPEND}"
+
+#WAF_BINARY="${S}/waf"
+
+DOCS=( ChangeLog README TODO )
+PATCHES=( "${FILESDIR}"/${P}-wscript_ldconfig.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+ append-ldflags -Wl,--soname=libnablah.so.0
+}
+
+src_install() {
+ waf-utils_src_install
+ dosym libnablah.so /usr/$(get_libdir)/libnablah.so.0
+}