summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-02-05 17:29:38 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-02-05 17:29:38 +0000
commit93410fb52de492e1b81ff922a88c73b328b55ac9 (patch)
tree535d35c1d259e6281606d1e6b1ea636fb419d1b7 /kde-misc
parentEAPI 5 (diff)
downloadgentoo-2-93410fb52de492e1b81ff922a88c73b328b55ac9.tar.gz
gentoo-2-93410fb52de492e1b81ff922a88c73b328b55ac9.tar.bz2
gentoo-2-93410fb52de492e1b81ff922a88c73b328b55ac9.zip
Add patch to prevent potential build failure wrt bug #538478.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog8
-rw-r--r--kde-misc/tellico/files/tellico-2.3.9-build.patch13
-rw-r--r--kde-misc/tellico/tellico-2.3.9.ebuild5
3 files changed, 22 insertions, 4 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 9edff6279322..cf41980ba11e 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/tellico
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.130 2014/12/12 15:44:33 zlogene Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.131 2015/02/05 17:29:38 kensington Exp $
+
+ 05 Feb 2015; Michael Palimaka <kensington@gentoo.org>
+ +files/tellico-2.3.9-build.patch, tellico-2.3.9.ebuild:
+ Add patch to prevent potential build failure wrt bug #538478.
12 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> tellico-2.3.9.ebuild:
amd64 stable wrt bug #517344
diff --git a/kde-misc/tellico/files/tellico-2.3.9-build.patch b/kde-misc/tellico/files/tellico-2.3.9-build.patch
new file mode 100644
index 000000000000..7724b4f897da
--- /dev/null
+++ b/kde-misc/tellico/files/tellico-2.3.9-build.patch
@@ -0,0 +1,13 @@
+Add a missing dependency which could cause a build failure.
+
+Fixes Gentoo bug #538478.
+
+diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
+index e44db7b..3b7a6bf 100644
+--- a/src/gui/CMakeLists.txt
++++ b/src/gui/CMakeLists.txt
+@@ -40,3 +40,4 @@ IF(${KDE_VERSION} VERSION_LESS "4.6.99" AND ${KDE_VERSION} VERSION_GREATER "4.5.
+ ENDIF(${KDE_VERSION} VERSION_LESS "4.6.99" AND ${KDE_VERSION} VERSION_GREATER "4.5.99")
+
+ KDE4_ADD_LIBRARY(gui STATIC ${gui_STAT_SRCS})
++ADD_DEPENDENCIES(gui tellico_config)
diff --git a/kde-misc/tellico/tellico-2.3.9.ebuild b/kde-misc/tellico/tellico-2.3.9.ebuild
index 3d243a732362..53821f4ead3c 100644
--- a/kde-misc/tellico/tellico-2.3.9.ebuild
+++ b/kde-misc/tellico/tellico-2.3.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.3.9.ebuild,v 1.4 2014/12/12 15:44:33 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.3.9.ebuild,v 1.5 2015/02/05 17:29:38 kensington Exp $
EAPI=5
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
# tests need network access and well-defined server responses
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${P}-build.patch")
DOCS=( AUTHORS ChangeLog README )
src_configure() {