summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-07-01 21:35:28 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-07-01 21:35:28 +0000
commit75c8a131ad3dac50dfcf7753a6f134b05989a119 (patch)
treed1778bb6b36e54a0664d59873c57e93737af5377 /kde-misc
parentadd docbook-xml-dtd-4.1.2 to DEPEND, fix bug #229077. (diff)
downloadgentoo-2-75c8a131ad3dac50dfcf7753a6f134b05989a119.tar.gz
gentoo-2-75c8a131ad3dac50dfcf7753a6f134b05989a119.tar.bz2
gentoo-2-75c8a131ad3dac50dfcf7753a6f134b05989a119.zip
Fix build with gcc 4.3, patch by Marek Miller.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/ksmoothdock/ChangeLog8
-rw-r--r--kde-misc/ksmoothdock/files/ksmoothdock-4.5-gcc43.patch82
-rw-r--r--kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild11
3 files changed, 97 insertions, 4 deletions
diff --git a/kde-misc/ksmoothdock/ChangeLog b/kde-misc/ksmoothdock/ChangeLog
index f0b996002857..789901fb2828 100644
--- a/kde-misc/ksmoothdock/ChangeLog
+++ b/kde-misc/ksmoothdock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/ksmoothdock
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksmoothdock/ChangeLog,v 1.28 2007/07/30 13:20:23 gustavoz Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksmoothdock/ChangeLog,v 1.29 2008/07/01 21:35:27 keytoaster Exp $
+
+ 01 Jul 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +files/ksmoothdock-4.5-gcc43.patch, ksmoothdock-4.5.ebuild:
+ Fix build with gcc 4.3, patch by Marek Miller.
30 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org>
ksmoothdock-4.5.ebuild:
diff --git a/kde-misc/ksmoothdock/files/ksmoothdock-4.5-gcc43.patch b/kde-misc/ksmoothdock/files/ksmoothdock-4.5-gcc43.patch
new file mode 100644
index 000000000000..257c33c95022
--- /dev/null
+++ b/kde-misc/ksmoothdock/files/ksmoothdock-4.5-gcc43.patch
@@ -0,0 +1,82 @@
+--- src/ksmoothdock.h.orig 2008-06-13 22:05:51.000000000 +0000
++++ src/ksmoothdock.h 2008-06-13 22:06:06.000000000 +0000
+@@ -27,6 +27,7 @@
+ #endif
+
+ #include <vector>
++#include <memory>
+
+ #include <qwidget.h>
+
+
+--- src/ksmoothdock.cpp.orig 2008-06-13 22:08:26.000000000 +0000
++++ src/ksmoothdock.cpp 2008-06-13 22:08:47.000000000 +0000
+@@ -24,6 +24,8 @@
+
+ #include <iostream>
+ #include <iterator>
++#include <typeinfo>
++
+
+ #include <qdir.h>
+
+
+--- src/buttonisedstate.h.orig 2008-06-13 22:10:48.000000000 +0000
++++ src/buttonisedstate.h 2008-06-13 22:11:03.000000000 +0000
+@@ -20,6 +20,8 @@
+ #ifndef BUTTONISEDSTATE_H
+ #define BUTTONISEDSTATE_H
+
++#include <memory>
++#include <typeinfo>
+ #include <qobject.h>
+ #include "dockstate.h"
+
+
+--- src/normalzoomstate.h.orig 2008-06-13 22:13:10.000000000 +0000
++++ src/normalzoomstate.h 2008-06-13 22:13:23.000000000 +0000
+@@ -20,6 +20,8 @@
+ #ifndef NORMALZOOMSTATE_H
+ #define NORMALZOOMSTATE_H
+
++#include <memory>
++
+ #include <qobject.h>
+ #include "dockstate.h"
+
+
+--- src/paraboliczoomstate.h.orig 2008-06-13 22:15:19.000000000 +0000
++++ src/paraboliczoomstate.h 2008-06-13 22:15:32.000000000 +0000
+@@ -20,6 +20,8 @@
+ #ifndef PARABOLICZOOMSTATE_H
+ #define PARABOLICZOOMSTATE_H
+
++#include <memory>
++#include <typeinfo>
+ #include <qobject.h>
+ #include "dockstate.h"
+
+--- src/normalzoomstate.cpp.orig 2008-06-13 22:22:16.000000000 +0000
++++ src/normalzoomstate.cpp 2008-06-13 22:22:28.000000000 +0000
+@@ -19,6 +19,8 @@
+ ***************************************************************************/
+ #include "normalzoomstate.h"
+
++
++#include <typeinfo>
+ #include <iostream>
+ #include <unistd.h>
+
+
+--- src/paraboliczoomstate.cpp.orig 2008-06-13 22:25:09.000000000 +0000
++++ src/paraboliczoomstate.cpp 2008-06-13 22:25:33.000000000 +0000
+@@ -19,6 +19,8 @@
+ ***************************************************************************/
+ #include "paraboliczoomstate.h"
+
++
++#include <cstdlib>
+ #include <iostream>
+ #include <unistd.h>
+
+
diff --git a/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild b/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild
index 77c253e57f74..e6344e5ea923 100644
--- a/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild
+++ b/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild,v 1.5 2007/07/30 13:20:23 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksmoothdock/ksmoothdock-4.5.ebuild,v 1.6 2008/07/01 21:35:27 keytoaster Exp $
inherit kde
@@ -17,3 +17,10 @@ KEYWORDS="amd64 ppc sparc x86"
IUSE=""
need-kde 3.4
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+