summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-07 15:16:50 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-07 15:16:50 +0000
commit59b5f68df182d9d88bdf7bd28ac283bde1b7fe54 (patch)
tree0b08c29b86a1b065b3ddf080541f29da852aa596 /kde-misc/kanyremote
parentFix bashcomp installation for bash-completon-1 users, bug 521166. (diff)
downloadgentoo-2-59b5f68df182d9d88bdf7bd28ac283bde1b7fe54.tar.gz
gentoo-2-59b5f68df182d9d88bdf7bd28ac283bde1b7fe54.tar.bz2
gentoo-2-59b5f68df182d9d88bdf7bd28ac283bde1b7fe54.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/ChangeLog7
-rw-r--r--kde-misc/kanyremote/kanyremote-6.3.4.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 5ee74e205faf..d477a7da8ede 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.43 2014/09/24 00:04:01 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.44 2014/10/07 15:16:50 mrueg Exp $
+
+*kanyremote-6.3.4 (07 Oct 2014)
+
+ 07 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +kanyremote-6.3.4.ebuild:
+ Version bump.
*kanyremote-6.3.3 (24 Sep 2014)
diff --git a/kde-misc/kanyremote/kanyremote-6.3.4.ebuild b/kde-misc/kanyremote/kanyremote-6.3.4.ebuild
new file mode 100644
index 000000000000..19e4feb56906
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.3.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.3.4.ebuild,v 1.1 2014/10/07 15:16:50 mrueg Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1 base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.0[bluetooth?]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}