summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-24 10:15:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-24 10:15:46 +0000
commit27518610d9b4dfc09b711dcf79c888eb82efd47f (patch)
tree2ac4173f62f4132ff9856409bea79956dbefef15 /kde-misc/kanyremote
parentx86 stable per bug 317517 (diff)
downloadgentoo-2-27518610d9b4dfc09b711dcf79c888eb82efd47f.tar.gz
gentoo-2-27518610d9b4dfc09b711dcf79c888eb82efd47f.tar.bz2
gentoo-2-27518610d9b4dfc09b711dcf79c888eb82efd47f.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/ChangeLog7
-rw-r--r--kde-misc/kanyremote/kanyremote-5.12.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 692cc484e487..10c1f415ab86 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.18 2011/02/13 20:04:41 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.19 2011/03/24 10:15:46 hwoarang Exp $
+
+*kanyremote-5.12 (24 Mar 2011)
+
+ 24 Mar 2011; Markos Chandras <hwoarang@gentoo.org> +kanyremote-5.12.ebuild:
+ Version bump
13 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> -kanyremote-5.11.ebuild:
old
diff --git a/kde-misc/kanyremote/kanyremote-5.12.ebuild b/kde-misc/kanyremote/kanyremote-5.12.ebuild
new file mode 100644
index 000000000000..b0c63cf78d40
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.12.ebuild,v 1.1 2011/03/24 10:15:46 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit autotools python base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=app-mobilephone/anyremote-4.4[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup () {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+ "${T}"/gettextize -f --no-changelog > /dev/null
+ #fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
+ eautoreconf
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}