summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 09:51:22 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 09:51:22 +0000
commite936a91e061cbddb64e7c091c70e956603a0aafa (patch)
treed05a111e8166736b44866ef6edd37b6b54d61352 /kde-base
parentVersion bump (diff)
downloadgentoo-2-e936a91e061cbddb64e7c091c70e956603a0aafa.tar.gz
gentoo-2-e936a91e061cbddb64e7c091c70e956603a0aafa.tar.bz2
gentoo-2-e936a91e061cbddb64e7c091c70e956603a0aafa.zip
Added patch from upstream to fix a memory leak.
(Portage version: 2.1.5)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kwin/ChangeLog6
-rw-r--r--kde-base/kwin/files/kwin-4.0.4-memory-leak.patch20
-rw-r--r--kde-base/kwin/kwin-4.0.4-r1.ebuild46
3 files changed, 71 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index a78e33acdd18..0dde51eebd02 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.125 2008/05/16 00:40:39 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.126 2008/05/16 09:51:21 ingmar Exp $
+
+ 16 May 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +files/kwin-4.0.4-memory-leak.patch, +kwin-4.0.4-r1.ebuild:
+ Added patch from upstream to fix a memory leak.
*kwin-4.0.4 (15 May 2008)
diff --git a/kde-base/kwin/files/kwin-4.0.4-memory-leak.patch b/kde-base/kwin/files/kwin-4.0.4-memory-leak.patch
new file mode 100644
index 000000000000..2b07df24c97a
--- /dev/null
+++ b/kde-base/kwin/files/kwin-4.0.4-memory-leak.patch
@@ -0,0 +1,20 @@
+--- kdebase/workspace/kwin/layers.cpp 2008/05/05 07:22:45 804132
++++ kdebase/workspace/kwin/layers.cpp 2008/05/05 07:23:32 804133
+@@ -721,7 +721,7 @@
+ ToplevelList Workspace::rootStackingOrder() const
+ {
+ Window dummy;
+- Window* windows;
++ Window* windows = NULL;
+ unsigned int count = 0;
+ XQueryTree( display(), rootWindow(), &dummy, &dummy, &windows, &count );
+ ToplevelList ret;
+@@ -736,6 +736,8 @@
+ }
+ foreach( Deleted* c, deleted )
+ ret.append( c );
++ if( windows != NULL )
++ XFree( windows );
+ return ret;
+ }
+
diff --git a/kde-base/kwin/kwin-4.0.4-r1.ebuild b/kde-base/kwin/kwin-4.0.4-r1.ebuild
new file mode 100644
index 000000000000..345c9324e99d
--- /dev/null
+++ b/kde-base/kwin/kwin-4.0.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.0.4-r1.ebuild,v 1.1 2008/05/16 09:51:21 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="captury debug opengl xcomposite xinerama"
+
+COMMONDEPEND="
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES="${FILESDIR}/${P}-memory-leak.patch"
+
+src_compile() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}