summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-30 11:46:59 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-30 11:46:59 +0000
commit993f09360674c41a98b1ac5db769653e8bc67e2e (patch)
treeb2c692ca6362a4e75445d2e8fd492c4dc93e0472 /kde-base
parentfixing bug #2095 (files installing into $D) (diff)
downloadgentoo-2-993f09360674c41a98b1ac5db769653e8bc67e2e.tar.gz
gentoo-2-993f09360674c41a98b1ac5db769653e8bc67e2e.tar.bz2
gentoo-2-993f09360674c41a98b1ac5db769653e8bc67e2e.zip
fixing bug #2093 (files installing into $D)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/ChangeLog8
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.0-r21
-rw-r--r--kde-base/kdebase/files/startkde-3.0-r2-gentoo.diff25
-rw-r--r--kde-base/kdebase/kdebase-3.0-r2.ebuild100
4 files changed, 133 insertions, 1 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index a6e8eff3e333..73782766310e 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.9 2002/04/13 19:14:25 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.10 2002/04/30 11:46:59 danarmak Exp $
+
+*kdebase-3.0-r2 (30 Apr 2002)
+
+ 30 Apr 2002; Dan Armak <danarmak@gentoo.org> Changelog :
+
+ Fix bug #2093 (files being installed into /var/tmp).
13 Apr 2002; Bart Verwilst <verwilst@gentoo.org>: Ok, just copied the
icons inside the pics dir to the /usr/share/pixmaps first :o) you never
diff --git a/kde-base/kdebase/files/digest-kdebase-3.0-r2 b/kde-base/kdebase/files/digest-kdebase-3.0-r2
new file mode 100644
index 000000000000..04b04780a78d
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.0-r2
@@ -0,0 +1 @@
+MD5 fc8092f16a6e26eeb01c161e60eaf3f2 kdebase-3.0.tar.bz2 13135392
diff --git a/kde-base/kdebase/files/startkde-3.0-r2-gentoo.diff b/kde-base/kdebase/files/startkde-3.0-r2-gentoo.diff
new file mode 100644
index 000000000000..1b3a5bc2277f
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-3.0-r2-gentoo.diff
@@ -0,0 +1,25 @@
+--- startkde Sun Mar 17 13:07:07 2002
++++ startkde Mon Mar 18 10:46:34 2002
+@@ -1,8 +1,20 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.0 )
++# Gentoo KDE STARTUP SCRIPT ( KDE-3.0 )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:${KDEDIRS}"
++export KDEMAINDIR="_KDEDIR_"
++rm -rf ~/.kde
++ln -fs ~/.kde3 ~/.kde
++[ -e "~/.kde3" ] || mkdir ~/.kde3
++
++
++# Original KDE part:
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
diff --git a/kde-base/kdebase/kdebase-3.0-r2.ebuild b/kde-base/kdebase/kdebase-3.0-r2.ebuild
new file mode 100644
index 000000000000..3c312e8c0666
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.0-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0-r2.ebuild,v 1.1 2002/04/30 11:46:59 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ media-sound/cdparanoia
+ opengl? ( virtual/opengl )" #this last for opengl screensavers
+# samba? ( net-fs/samba ) #use flag doesn't exist yet and we don't want such a heavy dep by deafult
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/konsole ${S}/konsole/konsole
+
+ cd ${S}/konsole
+ for x in Makefile.am Makefile.in; do
+ mv $x $x.orig
+ sed -e 's:tipdir = $(DESTDIR)/$(kde_datadir):tipdir = $(kde_datadir):g' \
+ -e 's:updatedir = $(DESTDIR)/$(kde_datadir):updatedir = $(kde_datadir):g' $x.orig > $x
+ done
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+ use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+ use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+ use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+ use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+ use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+ use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+ myconf="$myconf --with-dpms --with-cdparanoia"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ dodir ${KDEDIR}/share/templates/.source/emptydir
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-3.0,kde-2.2.2,:' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/usr/kde/3/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/usr/kde/3/share/apps/kdesktop/pics/
+ cd ${D}/usr/kde/3/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+}
+