summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
commitd184f1ab9f020bfde5c438ef4619ca58de2159f7 (patch)
tree7d64a3c945eda98cf0dbc517b9c12bbccf4f6c1e /kde-base/smokeqt
parentVersion bump (diff)
downloadgentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.gz
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.bz2
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.zip
Version bump KDE SC 4.14.2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.14.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index cac47c952454..23f1caaab78c 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.137 2014/09/16 18:17:22 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.138 2014/10/25 19:58:28 kensington Exp $
+
+*smokeqt-4.14.2 (25 Oct 2014)
+
+ 25 Oct 2014; Michael Palimaka <kensington@gentoo.org> +smokeqt-4.14.2.ebuild:
+ Version bump KDE SC 4.14.2
*smokeqt-4.14.1 (16 Sep 2014)
diff --git a/kde-base/smokeqt/smokeqt-4.14.2.ebuild b/kde-base/smokeqt/smokeqt-4.14.2.ebuild
new file mode 100644
index 000000000000..f5671fa34a45
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.14.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.14.2.ebuild,v 1.1 2014/10/25 19:58:28 kensington Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Smoke"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( media-libs/phonon[qt4] )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla:= )
+ qwt? ( x11-libs/qwt:5[svg] )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}