summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-17 18:50:30 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-17 18:50:30 +0000
commit08c927722b38bfbd2b07395876a13afcdae1008d (patch)
tree137a8601530da55d145091e44eb0677d989e052b /kde-base/print-manager
parentBackport multilib support into 1.5.4:0, for stabilization bug #524308. (diff)
downloadgentoo-2-08c927722b38bfbd2b07395876a13afcdae1008d.tar.gz
gentoo-2-08c927722b38bfbd2b07395876a13afcdae1008d.tar.bz2
gentoo-2-08c927722b38bfbd2b07395876a13afcdae1008d.zip
Fix build with cups-2.0, bug 525598
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/print-manager')
-rw-r--r--kde-base/print-manager/ChangeLog6
-rw-r--r--kde-base/print-manager/files/print-manager-4.14.1-cups20.patch72
-rw-r--r--kde-base/print-manager/print-manager-4.14.1.ebuild4
3 files changed, 80 insertions, 2 deletions
diff --git a/kde-base/print-manager/ChangeLog b/kde-base/print-manager/ChangeLog
index 8e7b266fd1d4..a2859fc8b191 100644
--- a/kde-base/print-manager/ChangeLog
+++ b/kde-base/print-manager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/print-manager
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/print-manager/ChangeLog,v 1.84 2014/09/16 18:17:33 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/print-manager/ChangeLog,v 1.85 2014/10/17 18:50:30 dilfridge Exp $
+
+ 17 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ print-manager-4.14.1.ebuild, +files/print-manager-4.14.1-cups20.patch:
+ Fix build with cups-2.0, bug 525598
*print-manager-4.14.1 (16 Sep 2014)
diff --git a/kde-base/print-manager/files/print-manager-4.14.1-cups20.patch b/kde-base/print-manager/files/print-manager-4.14.1-cups20.patch
new file mode 100644
index 000000000000..58c59dd61078
--- /dev/null
+++ b/kde-base/print-manager/files/print-manager-4.14.1-cups20.patch
@@ -0,0 +1,72 @@
+diff --git a/libkcups/KCupsConnection.cpp b/libkcups/KCupsConnection.cpp
+index 713be2f..335fc46 100644
+--- a/libkcups/KCupsConnection.cpp
++++ b/libkcups/KCupsConnection.cpp
+@@ -377,11 +377,11 @@ int KCupsConnection::renewDBusSubscription(int subscriptionId, int leaseDuration
+ response = request.sendIppRequest();
+ } while (retry("/", operation));
+
+-#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#if !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ if (response && ippGetStatusCode(response) == IPP_OK) {
+ #else
+ if (response && response->request.status.status_code == IPP_OK) {
+-#endif // CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#endif // !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ ipp_attribute_t *attr;
+ if (subscriptionId >= 0) {
+ // Request was ok, just return the current subscription
+@@ -392,7 +392,7 @@ int KCupsConnection::renewDBusSubscription(int subscriptionId, int leaseDuration
+ kWarning() << "No notify-subscription-id in response!";
+ ret = -1;
+ } else {
+-#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#if !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ ret = ippGetInteger(attr, 0);
+ }
+ } else if (subscriptionId >= 0 && response && ippGetStatusCode(response) == IPP_NOT_FOUND) {
+@@ -406,7 +406,7 @@ int KCupsConnection::renewDBusSubscription(int subscriptionId, int leaseDuration
+ kDebug() << "Subscription not found";
+ // When the subscription is not found try to get a new one
+ return renewDBusSubscription(-1, leaseDuration, events);
+-#endif // CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#endif // !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ } else {
+ kDebug() << "Request failed" << cupsLastError() << httpGetStatus(CUPS_HTTP_DEFAULT);
+ // When the server stops/restarts we will have some error so ignore it
+@@ -582,7 +582,7 @@ ReturnArguments KCupsConnection::parseIPPVars(ipp_t *response, ipp_tag_t group_t
+ ipp_attribute_t *attr;
+ ReturnArguments ret;
+
+-#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#if !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ QVariantHash destAttributes;
+ for (attr = ippFirstAttribute(response); attr != NULL; attr = ippNextAttribute(response)) {
+ // We hit an attribute sepparator
+@@ -659,7 +659,7 @@ ReturnArguments KCupsConnection::parseIPPVars(ipp_t *response, ipp_tag_t group_t
+ break;
+ }
+ }
+-#endif // CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#endif // !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+
+ return ret;
+ }
+@@ -667,7 +667,7 @@ ReturnArguments KCupsConnection::parseIPPVars(ipp_t *response, ipp_tag_t group_t
+ QVariant KCupsConnection::ippAttrToVariant(ipp_attribute_t *attr)
+ {
+ QVariant ret;
+-#if CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#if !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ switch (ippGetValueTag(attr)) {
+ case IPP_TAG_INTEGER:
+ case IPP_TAG_ENUM:
+@@ -760,7 +760,7 @@ QVariant KCupsConnection::ippAttrToVariant(ipp_attribute_t *attr)
+ ret = values;
+ }
+ }
+-#endif // CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR >= 6
++#endif // !(CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 6)
+ return ret;
+ }
+
diff --git a/kde-base/print-manager/print-manager-4.14.1.ebuild b/kde-base/print-manager/print-manager-4.14.1.ebuild
index b1122bfcec3b..53bf65ea8e39 100644
--- a/kde-base/print-manager/print-manager-4.14.1.ebuild
+++ b/kde-base/print-manager/print-manager-4.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/print-manager/print-manager-4.14.1.ebuild,v 1.1 2014/09/16 18:17:33 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/print-manager/print-manager-4.14.1.ebuild,v 1.2 2014/10/17 18:50:30 dilfridge Exp $
EAPI=5
@@ -19,3 +19,5 @@ RDEPEND="${DEPEND}
!kde-misc/print-manager
app-admin/system-config-printer-gnome
"
+
+PATCHES=( "${FILESDIR}/${PN}-4.14.1-cups20.patch" )