summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:59:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:59:57 +0000
commit1a9968363ded341f2adefc64aaf36f3b5c8f6d89 (patch)
treecf4459347766bd80983ff818a4e1145f2e1fe991 /kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-1a9968363ded341f2adefc64aaf36f3b5c8f6d89.tar.gz
gentoo-2-1a9968363ded341f2adefc64aaf36f3b5c8f6d89.tar.bz2
gentoo-2-1a9968363ded341f2adefc64aaf36f3b5c8f6d89.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild')
-rw-r--r--kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild b/kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild
new file mode 100644
index 000000000000..aa90043de90b
--- /dev/null
+++ b/kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/libkpimexchange-3.5.5.ebuild,v 1.1 2006/10/03 12:59:57 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE PIM exchange library"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcal)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcal libkcal"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/"
+
+src_compile() {
+ kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libkcal/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile make
+}