summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:22:49 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:22:49 +0000
commit78a17cdf570612a109ca3148ae986fa7fde7bb2d (patch)
treefa07284f25889084bab98f17fe38de9d6af3767e /kde-base/ksysguard
parentVersion bump KDE 4.2.4 (diff)
downloadgentoo-2-78a17cdf570612a109ca3148ae986fa7fde7bb2d.tar.gz
gentoo-2-78a17cdf570612a109ca3148ae986fa7fde7bb2d.tar.bz2
gentoo-2-78a17cdf570612a109ca3148ae986fa7fde7bb2d.zip
Version bump KDE 4.2.4
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.2.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 34e157b02b9c..592bc328c3da 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.135 2009/06/03 17:28:40 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.136 2009/06/04 13:22:49 alexxy Exp $
+
+*ksysguard-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> ChangeLog:
Drop KDE 4.2.2
diff --git a/kde-base/ksysguard/ksysguard-4.2.4.ebuild b/kde-base/ksysguard/ksysguard-4.2.4.ebuild
new file mode 100644
index 000000000000..8886390c4f37
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.2.4.ebuild,v 1.1 2009/06/04 13:22:49 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +handbook lm_sensors"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with lm_sensors Sensors)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # one out of two tests are broken. we just disable it. last tested on 4.1.0.
+ sed -e '/guitest/s/^/#DONOTTEST/' \
+ -i "${S}"/libs/ksysguard/tests/CMakeLists.txt
+
+ kde4-meta_src_test
+}