summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:06:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:06:22 +0000
commit2d1b14b557d12caf672f8b28d80e5400051a10fc (patch)
tree579a41d78e1873ed9b33a72b1c356c97b6455b5f /kde-base/ksplash
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-2d1b14b557d12caf672f8b28d80e5400051a10fc.tar.gz
gentoo-2-2d1b14b557d12caf672f8b28d80e5400051a10fc.tar.bz2
gentoo-2-2d1b14b557d12caf672f8b28d80e5400051a10fc.zip
Version bump KDE 4.3.2
(Portage version: 2.2_rc44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.3.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index d3e6840b6d32..9178d3aeb1f7 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.34 2009/09/01 15:58:30 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.35 2009/10/06 20:06:22 alexxy Exp $
+
+*ksplash-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +ksplash-4.3.2.ebuild:
+ Version bump
*ksplash-4.3.1 (01 Sep 2009)
diff --git a/kde-base/ksplash/ksplash-4.3.2.ebuild b/kde-base/ksplash/ksplash-4.3.2.ebuild
new file mode 100644
index 000000000000..72843e711aff
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.3.2.ebuild,v 1.1 2009/10/06 20:06:22 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}