summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-01-18 15:38:49 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-01-18 15:38:49 +0000
commit6b12a5cc9098612a5e71e762cc34181f972c410e (patch)
treecb6f6c31764d6cfaf29f959c864b368461e6dfbe /kde-base/kpilot
parentnew release (Manifest recommit) (diff)
downloadgentoo-2-6b12a5cc9098612a5e71e762cc34181f972c410e.tar.gz
gentoo-2-6b12a5cc9098612a5e71e762cc34181f972c410e.tar.bz2
gentoo-2-6b12a5cc9098612a5e71e762cc34181f972c410e.zip
Fix to properly detect pi-notepad.h.
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/kpilot-3.4.0_beta1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild b/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild
index ab87b6f14424..2d973720cbe5 100644
--- a/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild
+++ b/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:37 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.4.0_beta1.ebuild,v 1.2 2005/01/18 15:38:49 greg_g Exp $
KMNAME=kdepim
MAXKDEVER=$PV
@@ -28,3 +28,10 @@ KMEXTRACTONLY="
KMEXTRA="
kfile-plugins/palm-databases
kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}