summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/korganizer
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/korganizer')
-rw-r--r--kde-base/korganizer/ChangeLog7
-rw-r--r--kde-base/korganizer/korganizer-4.11.4.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/korganizer/ChangeLog b/kde-base/korganizer/ChangeLog
index 0c923b4032d8..c4cda0985906 100644
--- a/kde-base/korganizer/ChangeLog
+++ b/kde-base/korganizer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/korganizer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.297 2013/11/05 22:22:53 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.298 2013/12/03 22:36:06 johu Exp $
+
+*korganizer-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +korganizer-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*korganizer-4.11.3 (05 Nov 2013)
diff --git a/kde-base/korganizer/korganizer-4.11.4.ebuild b/kde-base/korganizer/korganizer-4.11.4.ebuild
new file mode 100644
index 000000000000..512cf9d14332
--- /dev/null
+++ b/kde-base/korganizer/korganizer-4.11.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/korganizer-4.11.4.ebuild,v 1.1 2013/12/03 22:36:06 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="A Personal Organizer for KDE"
+HOMEPAGE="http://www.kde.org/applications/office/korganizer/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep ktimezoned)
+"
+
+RESTRICT="test"
+# bug 393135
+
+KMLOADLIBS="kdepim-common-libs"
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarviews/
+ kdgantt2/
+ kmail/
+ pimcommon/
+ knode/org.kde.knode.xml
+ libkdepimdbusinterfaces/
+"
+
+KMCOMPILEONLY="
+ incidenceeditor-ng/
+ calendarsupport/
+"
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA}
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_install() {
+ kde4-meta_src_install
+ # colliding with kdepim-common-libs
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}