summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:10:22 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:10:22 +0000
commit2b7f34c1540303247cdb025c01b8591a500c4d3e (patch)
tree84c1f7a56e295f9afa800b13568e232fd086b7d3 /kde-base/kinfocenter
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-2b7f34c1540303247cdb025c01b8591a500c4d3e.tar.gz
gentoo-2-2b7f34c1540303247cdb025c01b8591a500c4d3e.tar.bz2
gentoo-2-2b7f34c1540303247cdb025c01b8591a500c4d3e.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kinfocenter')
-rw-r--r--kde-base/kinfocenter/ChangeLog9
-rw-r--r--kde-base/kinfocenter/kinfocenter-4.0.3.ebuild31
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kinfocenter/ChangeLog b/kde-base/kinfocenter/ChangeLog
index 09194e8d1f23..dcb067cf124c 100644
--- a/kde-base/kinfocenter/ChangeLog
+++ b/kde-base/kinfocenter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kinfocenter
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/ChangeLog,v 1.1 2008/03/10 23:41:07 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/ChangeLog,v 1.2 2008/04/03 21:10:22 philantrop Exp $
+
+*kinfocenter-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kinfocenter-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
*kinfocenter-4.0.2 (10 Mar 2008)
diff --git a/kde-base/kinfocenter/kinfocenter-4.0.3.ebuild b/kde-base/kinfocenter/kinfocenter-4.0.3.ebuild
new file mode 100644
index 000000000000..6a5a0ed4b8df
--- /dev/null
+++ b/kde-base/kinfocenter/kinfocenter-4.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/kinfocenter-4.0.3.ebuild,v 1.1 2008/04/03 21:10:22 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Info Center"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook ieee1394 opengl"
+
+DEPEND="!<kde-base/systemsettings-4.0.3:${SLOT}
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? ( virtual/glu virtual/opengl )"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils
+ sys-apps/usbutils"
+
+KMEXTRACTONLY="apps/cmake/modules/"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_compile
+}