summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-07-25 18:27:25 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-07-25 18:27:25 +0000
commitda420c68f0357f467d4fc2f637423490b5fb7ec6 (patch)
tree2ff6bfae896b7aa4c348f9f8405252c643c191eb /kde-base/kdepim
parentFinally removing 1.3.X series (diff)
downloadgentoo-2-da420c68f0357f467d4fc2f637423490b5fb7ec6.tar.gz
gentoo-2-da420c68f0357f467d4fc2f637423490b5fb7ec6.tar.bz2
gentoo-2-da420c68f0357f467d4fc2f637423490b5fb7ec6.zip
Multiple fixes. See the corresponding split ebuilds for more information.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'kde-base/kdepim')
-rw-r--r--kde-base/kdepim/ChangeLog7
-rw-r--r--kde-base/kdepim/files/digest-kdepim-3.5.7-r36
-rw-r--r--kde-base/kdepim/kdepim-3.5.7-r3.ebuild56
3 files changed, 68 insertions, 1 deletions
diff --git a/kde-base/kdepim/ChangeLog b/kde-base/kdepim/ChangeLog
index 354c1c638019..d7af7f21d994 100644
--- a/kde-base/kdepim/ChangeLog
+++ b/kde-base/kdepim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.275 2007/07/10 16:35:11 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.276 2007/07/25 18:27:25 carlo Exp $
+
+*kdepim-3.5.7-r3 (25 Jul 2007)
+
+ 25 Jul 2007; Carsten Lohrke <carlo@gentoo.org> +kdepim-3.5.7-r3.ebuild:
+ Multiple fixes. See the corresponding split ebuilds for more information.
*kdepim-3.5.7-r2 (10 Jul 2007)
diff --git a/kde-base/kdepim/files/digest-kdepim-3.5.7-r3 b/kde-base/kdepim/files/digest-kdepim-3.5.7-r3
new file mode 100644
index 000000000000..c779ca922394
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-3.5.7-r3
@@ -0,0 +1,6 @@
+MD5 bf6b46337388fa6a93c9084d3d2c4509 kdepim-3.5-patchset-04.tar.bz2 133990
+RMD160 9d9fd1e7b04512f1f28bba78d5eeadfc3e3280ba kdepim-3.5-patchset-04.tar.bz2 133990
+SHA256 8b1968a7bef8ab2efdb2d87e96943ce636775b76365bc1bc99e1e377f9abfc61 kdepim-3.5-patchset-04.tar.bz2 133990
+MD5 8571db6dcf4168614c96bb72c493f931 kdepim-3.5.7.tar.bz2 14166061
+RMD160 14c05d4620abf1eb5421ad434dc63f037069e930 kdepim-3.5.7.tar.bz2 14166061
+SHA256 9d981d372f1822662e102b6f84f046e4df771641fc4d041aae81b8fafd47b32e kdepim-3.5.7.tar.bz2 14166061
diff --git a/kde-base/kdepim/kdepim-3.5.7-r3.ebuild b/kde-base/kdepim/kdepim-3.5.7-r3.ebuild
new file mode 100644
index 000000000000..feef7a60358a
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.5.7-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.5.7-r3.ebuild,v 1.1 2007/07/25 18:27:25 carlo Exp $
+
+inherit kde-dist
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
+
+DESCRIPTION="KDE PIM (Personal Information Management) applications: KOrganizer, KMail, KNode,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt gnokii"
+
+RESTRICT="test"
+
+# We use GnuPG 1.4.x for OpenPGP and 1.9 (via gpgme) for s/mime as upstream advises.
+DEPEND="~kde-base/kdebase-${PV}
+ >=dev-libs/cyrus-sasl-2
+ gnokii? ( app-mobilephone/gnokii )
+ crypt? ( >=app-crypt/gpgme-1.1.2-r1
+ || ( >=app-crypt/gnupg-2.0.1-r1 <app-crypt/gnupg-1.9 ) )
+ x11-libs/libXScrnSaver
+ app-pda/libopensync"
+# Requires pilot-link-0.12.0
+# pda? ( >=app-pda/pilot-link-0.12.0 dev-libs/libmal )
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )"
+
+DEPEND="${DEPEND}
+ x11-proto/scrnsaverproto"
+
+src_unpack() {
+ kde_src_unpack
+ # Call Qt 3 designer
+ sed -i -e "s:\"designer\":\"${QTDIR}/bin/designer\":g" "${S}"/libkdepim/kcmdesignerfields.cpp || die "sed failed"
+
+ # disabling tests, see bug #164038 and bug #164097
+ sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" \
+ -i libkcal/Makefile.am || die "sed failed" || die "sed failed"
+# sed -e "s:SUBDIRS = . plugins test:SUBDIRS = . plugins:" \
+# -i kitchensync/libkonnector2/Makefile.am || die "sed failed"
+# sed -e "s:SUBDIRS = . tests test:SUBDIRS = .:" \
+# -i kitchensync/libksync/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+ local myconf="--with-sasl $(use_with gnokii)"
+ use crypt && myconf="${myconf} --with-gpg=/usr/bin/gpg"
+
+ # use pda || DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+ DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+
+ kde_src_compile
+}