summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-22 23:08:34 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-22 23:08:34 +0000
commit405bf946d6842bea9443945ae319b9e91dfe648c (patch)
tree835e05fcd19f143070c82ee732ad3c755cc930cb /kde-base/kdepim
parentVersion bump. (diff)
downloadgentoo-2-405bf946d6842bea9443945ae319b9e91dfe648c.tar.gz
gentoo-2-405bf946d6842bea9443945ae319b9e91dfe648c.tar.bz2
gentoo-2-405bf946d6842bea9443945ae319b9e91dfe648c.zip
Version bump.
(Portage version: 2.1.2.7)
Diffstat (limited to 'kde-base/kdepim')
-rw-r--r--kde-base/kdepim/ChangeLog7
-rw-r--r--kde-base/kdepim/files/digest-kdepim-3.5.73
-rw-r--r--kde-base/kdepim/kdepim-3.5.7.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/kdepim/ChangeLog b/kde-base/kdepim/ChangeLog
index 9ad6a8f6e25c..5564341a74f8 100644
--- a/kde-base/kdepim/ChangeLog
+++ b/kde-base/kdepim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.268 2007/05/21 03:21:17 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.269 2007/05/22 23:08:34 carlo Exp $
+
+*kdepim-3.5.7 (22 May 2007)
+
+ 22 May 2007; Carsten Lohrke <carlo@gentoo.org> +kdepim-3.5.7.ebuild:
+ Version bump.
21 May 2007; Joseph Jezak <josejx@gentoo.org> kdepim-3.5.5-r4.ebuild:
Marked ppc stable for bug #174678.
diff --git a/kde-base/kdepim/files/digest-kdepim-3.5.7 b/kde-base/kdepim/files/digest-kdepim-3.5.7
new file mode 100644
index 000000000000..01737c61da89
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-3.5.7
@@ -0,0 +1,3 @@
+MD5 8571db6dcf4168614c96bb72c493f931 kdepim-3.5.7.tar.bz2 14166061
+RMD160 14c05d4620abf1eb5421ad434dc63f037069e930 kdepim-3.5.7.tar.bz2 14166061
+SHA256 9d981d372f1822662e102b6f84f046e4df771641fc4d041aae81b8fafd47b32e kdepim-3.5.7.tar.bz2 14166061
diff --git a/kde-base/kdepim/kdepim-3.5.7.ebuild b/kde-base/kdepim/kdepim-3.5.7.ebuild
new file mode 100644
index 000000000000..62dac2ef2691
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.5.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.5.7.ebuild,v 1.1 2007/05/22 23:08:34 carlo Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE PIM (Personal Information Management) applications: KOrganizer, KMail, KNode,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="crypt gnokii"
+
+# We use GnuPG 1.4.x for OpenPGP and 1.9 (via gpgme) for s/mime as upstream advises.
+DEPEND="~kde-base/kdebase-${PV}
+ >=dev-libs/cyrus-sasl-2
+ gnokii? ( app-mobilephone/gnokii )
+ crypt? ( >=app-crypt/gpgme-1.1.2-r1
+ || ( >=app-crypt/gnupg-2.0.1-r1 <app-crypt/gnupg-1.9 ) )
+ x11-libs/libXScrnSaver
+ app-pda/libopensync"
+# Requires pilot-link-0.12.0
+# pda? ( >=app-pda/pilot-link-0.12.0 dev-libs/libmal )
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )"
+
+DEPEND="${DEPEND}
+ x11-proto/scrnsaverproto"
+
+src_unpack() {
+ kde_src_unpack
+ # Call Qt 3 designer
+ sed -i -e "s:\"designer\":\"${QTDIR}/bin/designer\":g" "${S}"/libkdepim/kcmdesignerfields.cpp || die "sed failed"
+
+ # disabling tests, see bug #164038 and bug #164097
+ sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" \
+ -i libkcal/Makefile.am || die "sed failed" || die "sed failed"
+# sed -e "s:SUBDIRS = . plugins test:SUBDIRS = . plugins:" \
+# -i kitchensync/libkonnector2/Makefile.am || die "sed failed"
+# sed -e "s:SUBDIRS = . tests test:SUBDIRS = .:" \
+# -i kitchensync/libksync/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+ local myconf="--with-sasl $(use_with gnokii)"
+ use crypt && myconf="${myconf} --with-gpg=/usr/bin/gpg"
+
+ # use pda || DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+ DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+
+ kde_src_compile
+}