summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/kdepim-common-libs
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-common-libs')
-rw-r--r--kde-base/kdepim-common-libs/ChangeLog8
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.12.0.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-base/kdepim-common-libs/ChangeLog b/kde-base/kdepim-common-libs/ChangeLog
index b307a6710e0c..24f6af0cdb00 100644
--- a/kde-base/kdepim-common-libs/ChangeLog
+++ b/kde-base/kdepim-common-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-common-libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.121 2013/12/12 03:36:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.122 2013/12/18 19:58:08 johu Exp $
+
+*kdepim-common-libs-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org>
+ +kdepim-common-libs-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org>
-kdepim-common-libs-4.10.5.ebuild:
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.12.0.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.12.0.ebuild
new file mode 100644
index 000000000000..7aea69c3ab77
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.12.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.12.0.ebuild,v 1.1 2013/12/18 19:58:08 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.10.43
+ dev-libs/grantlee
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}
+ !kde-base/akonadi:4
+ !kde-base/libkdepim:4
+ !kde-base/libkleo:4
+ !kde-base/libkpgp:4
+ !<kde-base/kaddressbook-4.11.50:4
+ !kde-base/kdepim-wizards:4
+ !<kde-base/kmail-4.4.80:4
+ !<kde-base/korganizer-4.5.67:4
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+RESTRICT="test"
+# bug 393131
+
+KMEXTRA="
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ composereditor-ng/
+ grantleetheme/
+ kaddressbookgrantlee/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kdgantt2/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ ontologies/
+ pimcommon/
+ templateparser/
+"
+KMEXTRACTONLY="
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/org.kde.korganizer.Korganizer.xml
+"
+KMCOMPILEONLY="
+ agents/sendlateragent
+"
+
+KMSAVELIBS="true"
+
+PATCHES=( "${FILESDIR}/install-composereditorng.patch" )