summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-07 14:13:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-07 14:13:57 +0000
commit2a06154ff4a54e67a586cc6b84b859d7a8e64b17 (patch)
treeafa01f1bbdd6d1138ae0aabaa00df2294313998c /kde-base/kdenetwork
parentAdd support to make ruby optional when inheriting the eclass. (diff)
downloadgentoo-2-2a06154ff4a54e67a586cc6b84b859d7a8e64b17.tar.gz
gentoo-2-2a06154ff4a54e67a586cc6b84b859d7a8e64b17.tar.bz2
gentoo-2-2a06154ff4a54e67a586cc6b84b859d7a8e64b17.zip
Check for opengl useflag in Qt before compiling. See bug #139122.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'kde-base/kdenetwork')
-rw-r--r--kde-base/kdenetwork/ChangeLog7
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.2.ebuild17
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild17
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.3.ebuild17
4 files changed, 45 insertions, 13 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index dc0988fe960b..710764e956d5 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdenetwork
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.207 2006/06/15 00:07:45 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.208 2006/07/07 14:13:57 flameeyes Exp $
+
+ 07 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kdenetwork-3.5.2.ebuild, kdenetwork-3.5.3.ebuild,
+ kdenetwork-3.5.3-r1.ebuild:
+ Check for opengl useflag in Qt before compiling. See bug #139122.
*kdenetwork-3.5.3-r1 (15 Jun 2006)
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild
index c5483fd5d636..ba6b21a61764 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild,v 1.10 2006/06/03 11:01:19 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.2.ebuild,v 1.11 2006/07/07 14:13:57 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -47,13 +47,22 @@ DEPEND="${BOTH_DEPEND}
PATCHES="${FILESDIR}/kppp-3.5.0-bindnow.patch
${FILESDIR}/lisa-3.5.0-bindnow.patch"
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
src_compile() {
export BINDNOW_FLAGS="$(bindnow-flags)"
local myconf="--with-libidn
- $(use_enable sametime sametime-plugin)
- $(use_enable slp) $(use_with wifi)
- $(use_with xmms) --without-external-libgadu"
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi)
+ $(use_with xmms) --without-external-libgadu"
kde_src_compile
}
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild
index fc7d5ac2ca2e..1b7e0fa44cbc 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild,v 1.1 2006/06/15 00:07:46 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild,v 1.2 2006/07/07 14:13:57 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -47,13 +47,22 @@ DEPEND="${BOTH_DEPEND}
) virtual/x11 )
dev-util/pkgconfig"
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
src_compile() {
export BINDNOW_FLAGS="$(bindnow-flags)"
local myconf="--with-libidn
- $(use_enable sametime sametime-plugin)
- $(use_enable slp) $(use_with wifi)
- $(use_with xmms) --without-external-libgadu"
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi)
+ $(use_with xmms) --without-external-libgadu"
kde_src_compile
}
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild
index cb5483862f0c..ba0d6b1aa634 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild,v 1.1 2006/06/02 20:09:59 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3.ebuild,v 1.2 2006/07/07 14:13:57 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -47,13 +47,22 @@ DEPEND="${BOTH_DEPEND}
PATCHES="${FILESDIR}/kppp-3.5.0-bindnow.patch
${FILESDIR}/lisa-3.5.0-bindnow.patch"
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
src_compile() {
export BINDNOW_FLAGS="$(bindnow-flags)"
local myconf="--with-libidn
- $(use_enable sametime sametime-plugin)
- $(use_enable slp) $(use_with wifi)
- $(use_with xmms) --without-external-libgadu"
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi)
+ $(use_with xmms) --without-external-libgadu"
kde_src_compile
}