summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 15:04:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 15:04:47 +0000
commitf3c2b792d84e308b9b2074898c28f62002141228 (patch)
tree64de9524b756b7e0dff6c7cbe849ef006300a060 /kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild
parentVersion bump KDE 4.3.5 (diff)
downloadgentoo-2-f3c2b792d84e308b9b2074898c28f62002141228.tar.gz
gentoo-2-f3c2b792d84e308b9b2074898c28f62002141228.tar.bz2
gentoo-2-f3c2b792d84e308b9b2074898c28f62002141228.zip
Version bump KDE 4.3.5
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild')
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild
new file mode 100644
index 000000000000..257c793fbd74
--- /dev/null
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.5.ebuild,v 1.1 2010/01/25 15:04:47 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="csharp"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta mono
+
+DESCRIPTION="C# bindings for KDE and Qt"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi +phonon plasma qscintilla"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smoke 'akonadi?,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="smoke/"
+
+PATCHES=( "${FILESDIR}"/${PN}-build-fixes.patch )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+
+ if use plasma && ! use webkit; then
+ eerror
+ eerror "The plasma USE flag requires the webkit USE flag to be enabled."
+ eerror
+ eerror "Please enable webkit or disable plasma."
+ die "plasma requires webkit"
+ fi
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" csharp/plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable webkit QTWEBKIT_SHARP)
+ $(cmake-utils_use_enable plasma PLASMA_SHARP)
+ $(cmake-utils_use_enable phonon PHONON_SHARP)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_SHARP)
+ $(cmake-utils_use_enable akonadi KdepimLibs)
+ $(cmake-utils_use_enable akonadi)
+ )
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ # Parallel builds seem broken, check later
+ MAKEOPTS=-j1
+ kde4-meta_src_compile
+}