summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-29 03:15:47 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-29 03:15:47 +0000
commit525e6e28517f4ce204b4a5c021263df48ebba84a (patch)
tree05f22d8bdf0ea8fc1458a7f61852dfad6390c951 /kde-base/kdeaddons
parentupdated warning message (Manifest recommit) (diff)
downloadgentoo-2-525e6e28517f4ce204b4a5c021263df48ebba84a.tar.gz
gentoo-2-525e6e28517f4ce204b4a5c021263df48ebba84a.tar.bz2
gentoo-2-525e6e28517f4ce204b4a5c021263df48ebba84a.zip
gcc 3.4 fix
Diffstat (limited to 'kde-base/kdeaddons')
-rw-r--r--kde-base/kdeaddons/ChangeLog6
-rw-r--r--kde-base/kdeaddons/files/kdeaddons-3.2.2-gcc34.patch28
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.2.2.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/kde-base/kdeaddons/ChangeLog b/kde-base/kdeaddons/ChangeLog
index f49e2d631984..94fd9aa87ca8 100644
--- a/kde-base/kdeaddons/ChangeLog
+++ b/kde-base/kdeaddons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdeaddons
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.80 2004/04/21 01:45:02 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.81 2004/04/29 03:15:47 lv Exp $
+
+ 28 Apr 2004; Travis Tilley <lv@gentoo.org>
+ +files/kdeaddons-3.2.2-gcc34.patch, kdeaddons-3.2.2.ebuild:
+ added fix for compiling with gcc 3.4
20 Apr 2004; Caleb Tennis <caleb@gentoo.org> -kdeaddons-3.0.5b.ebuild:
Remove old version
diff --git a/kde-base/kdeaddons/files/kdeaddons-3.2.2-gcc34.patch b/kde-base/kdeaddons/files/kdeaddons-3.2.2-gcc34.patch
new file mode 100644
index 000000000000..75ab7123e372
--- /dev/null
+++ b/kde-base/kdeaddons/files/kdeaddons-3.2.2-gcc34.patch
@@ -0,0 +1,28 @@
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h
+--- noatun-plugins/synaescope/polygon.h 2001-04-17 03:20:34.000000000 +0400
++++ noatun-plugins/synaescope/polygon.h 2004-04-24 09:51:48.355249296 +0400
+@@ -25,6 +25,10 @@
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel>
+ {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h
+--- noatun-plugins/tippercanoe/polygon.h 2001-04-17 02:04:03.000000000 +0400
++++ noatun-plugins/tippercanoe/polygon.h 2004-04-24 09:58:30.243153048 +0400
+@@ -23,6 +23,10 @@
+
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel> {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
diff --git a/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild b/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild
index 2f3069ef6362..64defab75e06 100644
--- a/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild
+++ b/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild,v 1.1 2004/04/20 01:43:00 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.2.ebuild,v 1.2 2004/04/29 03:15:47 lv Exp $
inherit kde-dist flag-o-matic
@@ -25,3 +25,5 @@ use xmms || export ac_cv_have_xmms=no
# This should continue to apply to upcoming versions since it's
# Gentoo-specific and won't go upstream.
PATCHES="$FILESDIR/${PN}-3.2.0-kvim.diff"
+# fix needed for compiling with gcc 3.4
+PATCHES="${PATCHES} ${FILESDIR}/${P}-gcc34.patch"