summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-01 10:03:35 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-01 10:03:35 +0000
commit8d190ab8bdc05e4d49159a50d0cdc6d733e0404c (patch)
tree36f0db2ced33d9a623243eb8dfd6bfea61a0dbb5 /kde-base/kate
parentVersion bump KDE 4.3.4 (diff)
downloadgentoo-2-8d190ab8bdc05e4d49159a50d0cdc6d733e0404c.tar.gz
gentoo-2-8d190ab8bdc05e4d49159a50d0cdc6d733e0404c.tar.bz2
gentoo-2-8d190ab8bdc05e4d49159a50d0cdc6d733e0404c.zip
Version bump KDE 4.3.4
(Portage version: 2.2_rc54/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.3.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 078ccd8da5b0..503f57f62e8b 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.156 2009/11/30 06:54:39 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.157 2009/12/01 10:03:35 wired Exp $
+
+*kate-4.3.4 (01 Dec 2009)
+
+ 01 Dec 2009; Alex Alexander <wired@gentoo.org> +kate-4.3.4.ebuild:
+ Version bump
30 Nov 2009; Joseph Jezak <josejx@gentoo.org> kate-4.3.3.ebuild:
Marked ppc/ppc64 stable for bug #292455.
diff --git a/kde-base/kate/kate-4.3.4.ebuild b/kde-base/kate/kate-4.3.4.ebuild
new file mode 100644
index 000000000000..5901cd75553f
--- /dev/null
+++ b/kde-base/kate/kate-4.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.3.4.ebuild,v 1.1 2009/12/01 10:03:35 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}