summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-02 16:48:19 +0000
committerJohannes Huber <johu@gentoo.org>2013-07-02 16:48:19 +0000
commit02902daa78c7cf5f5386400ee0dafd0414609a10 (patch)
tree16905afe90080dedca0abd945f2f302b80b0b3e1 /kde-base/kate
parentMove `ln` update to the patch rather than sed-ing it after the fact #475334 b... (diff)
downloadgentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.tar.gz
gentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.tar.bz2
gentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.zip
Version bump KDE SC 4.10.5
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.10.5.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index ef5bc69ed03a..cd6fbedc6e7f 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.289 2013/07/02 09:29:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.290 2013/07/02 16:47:40 johu Exp $
+
+*kate-4.10.5 (02 Jul 2013)
+
+ 02 Jul 2013; Johannes Huber <johu@gentoo.org> +kate-4.10.5.ebuild:
+ Version bump KDE SC 4.10.5
02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> -kate-4.10.3.ebuild:
Remove old
diff --git a/kde-base/kate/kate-4.10.5.ebuild b/kde-base/kate/kate-4.10.5.ebuild
new file mode 100644
index 000000000000..f6a2aecba5af
--- /dev/null
+++ b/kde-base/kate/kate-4.10.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.10.5.ebuild,v 1.1 2013/07/02 16:47:40 johu Exp $
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} )
+
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ python? (
+ ${PYTHON_DEPEND}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build python pate)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}