summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
commitad239490ed9eef8b7e06727b919d4593f51667ae (patch)
tree86688474b00c8427904e72d675cbe3d82b38d1c2 /kde-base/dolphin-plugins
parentVersion bump. (diff)
downloadgentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.gz
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.bz2
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.zip
Version bump KDE SC 4.13.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog7
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.13.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 1caa4b12f88a..96c0b15f9457 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.155 2014/05/08 10:31:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.156 2014/05/13 17:43:45 johu Exp $
+
+*dolphin-plugins-4.13.1 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org> +dolphin-plugins-4.13.1.ebuild:
+ Version bump KDE SC 4.13.1
08 May 2014; Agostino Sarubbo <ago@gentoo.org> -dolphin-plugins-4.11.5.ebuild:
Remove old
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.13.1.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.13.1.ebuild
new file mode 100644
index 000000000000..f3f80ebd99e3
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.13.1.ebuild,v 1.1 2014/05/13 17:43:45 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}