summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb9d227823671a4217d7d0f9e194c5108eacc548e (patch)
tree8d57d37d8c5552901a88ade2d47df6941892d5aa /kde-base/audiocd-kio
parentStable for HPPA (bug #444546). (diff)
downloadgentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.gz
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.bz2
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.zip
[kde-base] Add KDE SC 4.9.4
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/audiocd-kio')
-rw-r--r--kde-base/audiocd-kio/ChangeLog7
-rw-r--r--kde-base/audiocd-kio/audiocd-kio-4.9.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/audiocd-kio/ChangeLog b/kde-base/audiocd-kio/ChangeLog
index c3500cf30dfd..087b429fa737 100644
--- a/kde-base/audiocd-kio/ChangeLog
+++ b/kde-base/audiocd-kio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/audiocd-kio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/ChangeLog,v 1.11 2012/11/30 15:15:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/ChangeLog,v 1.12 2012/12/05 16:57:41 alexxy Exp $
+
+*audiocd-kio-4.9.4 (05 Dec 2012)
+
+ 05 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +audiocd-kio-4.9.4.ebuild:
+ Version bump KDE SC 4.9.4
30 Nov 2012; <ago@gentoo.org> audiocd-kio-4.9.3.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/kde-base/audiocd-kio/audiocd-kio-4.9.4.ebuild b/kde-base/audiocd-kio/audiocd-kio-4.9.4.ebuild
new file mode 100644
index 000000000000..f1db1413cbbb
--- /dev/null
+++ b/kde-base/audiocd-kio/audiocd-kio-4.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/audiocd-kio-4.9.4.ebuild,v 1.1 2012/12/05 16:57:41 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE kioslaves from the kdemultimedia package"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug encode flac vorbis"
+
+# 4 of 9 tests fail. Last checked for 4.2.88
+RESTRICT=test
+
+DEPEND="
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ media-sound/cdparanoia
+ encode? (
+ flac? ( >=media-libs/flac-1.1.2 )
+ vorbis? ( media-libs/libvorbis )
+ )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kdemultimedia-kioslaves
+
+KMLOADLIBS="libkcddb"
+
+src_configure() {
+ if use encode; then
+ mycmakeargs=(
+ $(cmake-utils_use_with flac)
+ $(cmake-utils_use_with vorbis OggVorbis)
+ )
+ else
+ mycmakeargs=(-DWITH_OggVorbis=OFF -DWITH_Flac=OFF)
+ fi
+
+ kde4-base_src_configure
+}