summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-05-10 19:03:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-05-10 19:03:04 +0000
commit382ed5fa110d17f6dad422b2be2fff508dfc1777 (patch)
treea7e2591a056852a317964651538da36bc29e6ea5 /gnustep-base/gnustep-back-art
parentStable release bump (diff)
downloadgentoo-2-382ed5fa110d17f6dad422b2be2fff508dfc1777.tar.gz
gentoo-2-382ed5fa110d17f6dad422b2be2fff508dfc1777.tar.bz2
gentoo-2-382ed5fa110d17f6dad422b2be2fff508dfc1777.zip
Stable release bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base/gnustep-back-art')
-rw-r--r--gnustep-base/gnustep-back-art/ChangeLog8
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.18.0.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-back-art/ChangeLog b/gnustep-base/gnustep-back-art/ChangeLog
index bfdd884336a8..70d24b1de5cb 100644
--- a/gnustep-base/gnustep-back-art/ChangeLog
+++ b/gnustep-base/gnustep-back-art/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-back-art
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.72 2010/02/10 21:52:50 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.73 2010/05/10 19:03:04 voyageur Exp $
+
+*gnustep-back-art-0.18.0 (10 May 2010)
+
+ 10 May 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-back-art-0.18.0.ebuild:
+ Stable release bump
10 Feb 2010; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-back-art-0.14.0.ebuild:
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.18.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.18.0.ebuild
new file mode 100644
index 000000000000..f14ea74cae95
--- /dev/null
+++ b/gnustep-base/gnustep-back-art/gnustep-back-art-0.18.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/gnustep-back-art-0.18.0.ebuild,v 1.1 2010/05/10 19:03:04 voyageur Exp $
+
+inherit gnustep-base
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="opengl xim"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-gui-${PV}
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ dev-libs/expat
+ media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ >=media-libs/libart_lgpl-2.3
+ >=gnustep-base/mknfonts-0.5-r1
+ media-fonts/dejavu
+ !gnustep-base/gnustep-back-cairo
+ !gnustep-base/gnustep-back-xlib"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=art"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+
+ # Create font lists for DejaVu
+ einfo "Generating nfonts support files"
+ cd Fonts
+ ${GNUSTEP_SYSTEM_TOOLS}/mknfonts \
+ $(fc-list : file|grep -v '\.gz'|cut -d: -f1) \
+ || die "nfonts support files creation failed"
+ # Trim whitepsaces
+ for fdir in *\ */; do
+ mv "$fdir" `echo $fdir | tr -d [:space:]`
+ done
+}
+
+src_install() {
+ egnustep_env
+
+ gnustep-base_src_install
+
+ mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
+ cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
+}
+
+gnustep_config_script() {
+ echo "echo ' * setting normal font to DejaVuSans'"
+ echo "defaults write NSGlobalDomain NSFont DejaVuSans"
+ echo "echo ' * setting bold font to DejaVuSans-Bold'"
+ echo "defaults write NSGlobalDomain NSBoldFont DejaVuSans-Bold"
+ echo "echo ' * setting fixed font to DejaVuSansMono'"
+ echo "defaults write NSGlobalDomain NSUserFixedPitchFont DejaVuSansMono"
+}