summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-10-05 16:27:18 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-10-05 16:27:18 +0000
commit978e21289f8e7196c7e004c3700272e57786ff31 (patch)
treeb98c0c31bdef0722e2a70f93d7a3414a0349de0a /gnustep-apps/recycler
parentbump 2.16-r2 on mips (Manifest recommit) (diff)
downloadgentoo-2-978e21289f8e7196c7e004c3700272e57786ff31.tar.gz
gentoo-2-978e21289f8e7196c7e004c3700272e57786ff31.tar.bz2
gentoo-2-978e21289f8e7196c7e004c3700272e57786ff31.zip
Broke apart some optional components from gworkspace; added gnustep-apps/desktop gnustep-apps/recycler; gnustep-apps/gwnet
Diffstat (limited to 'gnustep-apps/recycler')
-rw-r--r--gnustep-apps/recycler/ChangeLog10
-rw-r--r--gnustep-apps/recycler/Manifest3
-rw-r--r--gnustep-apps/recycler/files/digest-recycler-0.7_pre200409280
-rw-r--r--gnustep-apps/recycler/files/seperate-build.patch56
-rw-r--r--gnustep-apps/recycler/metadata.xml8
-rw-r--r--gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild35
6 files changed, 112 insertions, 0 deletions
diff --git a/gnustep-apps/recycler/ChangeLog b/gnustep-apps/recycler/ChangeLog
new file mode 100644
index 000000000000..2a4512ae01a1
--- /dev/null
+++ b/gnustep-apps/recycler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-apps/recycler
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/recycler/ChangeLog,v 1.1 2004/10/05 16:26:40 fafhrd Exp $
+
+*recycler-0.7_pre20040928 (05 Oct 2004)
+
+ 05 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +files/seperate-build.patch, +recycler-0.7_pre20040928.ebuild:
+ Original package import.
+
diff --git a/gnustep-apps/recycler/Manifest b/gnustep-apps/recycler/Manifest
new file mode 100644
index 000000000000..e9a4d079c91f
--- /dev/null
+++ b/gnustep-apps/recycler/Manifest
@@ -0,0 +1,3 @@
+MD5 ada18eaded6c6a9f71b2a0f0a5c743bd recycler-0.7_pre20040928.ebuild 811
+MD5 87d1c55f65942899d02fea4a72e0734b metadata.xml 221
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-recycler-0.7_pre20040928 0
diff --git a/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928 b/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928
diff --git a/gnustep-apps/recycler/files/seperate-build.patch b/gnustep-apps/recycler/files/seperate-build.patch
new file mode 100644
index 000000000000..b1594509fdd8
--- /dev/null
+++ b/gnustep-apps/recycler/files/seperate-build.patch
@@ -0,0 +1,56 @@
+diff -ur Recycler.old/Recycler.m Recycler/Recycler.m
+--- Recycler.old/Recycler.m 2004-09-21 20:00:27.000000000 -0400
++++ Recycler/Recycler.m 2004-10-05 11:58:44.337684960 -0400
+@@ -28,10 +28,10 @@
+ #include "RecyclerView.h"
+ #include "Preferences/RecyclerPrefs.h"
+ #include "Dialogs/StartAppWin.h"
+-#include "FSNode.h"
+-#include "FSNodeRep.h"
+-#include "FSNFunctions.h"
+-#include "GNUstep.h"
++#include "FSNode/FSNode.h"
++#include "FSNode/FSNodeRep.h"
++#include "FSNode/FSNFunctions.h"
++//#include "GNUstep.h"
+
+
+ static Recycler *recycler = nil;
+diff -ur Recycler.old/RecyclerIcon.h Recycler/RecyclerIcon.h
+--- Recycler.old/RecyclerIcon.h 2004-06-15 06:20:26.000000000 -0400
++++ Recycler/RecyclerIcon.h 2004-10-05 11:58:59.077444176 -0400
+@@ -26,7 +26,7 @@
+ #define RECYCLER_ICON_H
+
+ #include <AppKit/NSView.h>
+-#include "FSNIcon.h"
++#include "FSNode/FSNIcon.h"
+
+ @class NSColor;
+ @class NSImage;
+diff -ur Recycler.old/RecyclerView.h Recycler/RecyclerView.h
+--- Recycler.old/RecyclerView.h 2004-09-02 07:31:38.000000000 -0400
++++ Recycler/RecyclerView.h 2004-10-05 11:58:15.332094480 -0400
+@@ -27,7 +27,7 @@
+
+ #include <AppKit/NSView.h>
+ #include "Recycler.h"
+-#include "FSNodeRep.h"
++#include "FSNode/FSNodeRep.h"
+
+ @class NSImage;
+ @class RecyclerIcon;
+diff -ur Recycler.old/RecyclerView.m Recycler/RecyclerView.m
+--- Recycler.old/RecyclerView.m 2004-09-21 20:00:27.000000000 -0400
++++ Recycler/RecyclerView.m 2004-10-05 11:59:18.241530792 -0400
+@@ -27,8 +27,8 @@
+ #include <math.h>
+ #include "RecyclerView.h"
+ #include "RecyclerIcon.h"
+-#include "FSNFunctions.h"
+-#include "GNUstep.h"
++#include "FSNode/FSNFunctions.h"
++//#include "GNUstep.h"
+
+ #define WIN_SIZE 64
+ #define ICN_SIZE 48
diff --git a/gnustep-apps/recycler/metadata.xml b/gnustep-apps/recycler/metadata.xml
new file mode 100644
index 000000000000..ef0d9002601e
--- /dev/null
+++ b/gnustep-apps/recycler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+A recycler for GNUstep.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild b/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild
new file mode 100644
index 000000000000..976c80eac3de
--- /dev/null
+++ b/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild,v 1.1 2004/10/05 16:26:40 fafhrd Exp $
+
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/usr-apps/gworkspace/${PN/r/R}"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="A recycler for GNUstep."
+HOMEPAGE="http://www.gnustep.it/enrico/gworkspace/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="${IUSE}"
+DEPEND="${GS_DEPEND}
+ gnustep-apps/gworkspace"
+RDEPEND="${GS_RDEPEND}
+ gnustep-apps/gworkspace"
+
+src_compile() {
+ egnustep_env
+ EPATCH_OPTIONS="-d ${S}" epatch ${FILESDIR}/seperate-build.patch
+ egnustep_make
+}
+