summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-12-24 16:49:21 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-12-24 16:49:21 +0000
commitbf90ede65c7588c9015b4e391757397a1e65e021 (patch)
tree803c34e1e968d639e20545e3ffc678b6f4633132 /gnome-extra
parentVersion bump. (diff)
downloadgentoo-2-bf90ede65c7588c9015b4e391757397a1e65e021.tar.gz
gentoo-2-bf90ede65c7588c9015b4e391757397a1e65e021.tar.bz2
gentoo-2-bf90ede65c7588c9015b4e391757397a1e65e021.zip
Add system nspr cflags, fixes build with xulrunner-1.9.2, bug 295016
(Portage version: 2.1.7.15/cvs/Linux i686)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yelp/ChangeLog8
-rw-r--r--gnome-extra/yelp/files/yelp-2.28.1-system-nspr.patch15
-rw-r--r--gnome-extra/yelp/yelp-2.28.1-r1.ebuild72
3 files changed, 94 insertions, 1 deletions
diff --git a/gnome-extra/yelp/ChangeLog b/gnome-extra/yelp/ChangeLog
index 46eddc2c5157..a9be8cfe992e 100644
--- a/gnome-extra/yelp/ChangeLog
+++ b/gnome-extra/yelp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/yelp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.225 2009/12/03 17:04:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.226 2009/12/24 16:49:21 nirbheek Exp $
+
+*yelp-2.28.1-r1 (24 Dec 2009)
+
+ 24 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +yelp-2.28.1-r1.ebuild, +files/yelp-2.28.1-system-nspr.patch:
+ Add system nspr cflags, fixes build with xulrunner-1.9.2, bug 295016
03 Dec 2009; Brent Baude <ranger@gentoo.org> yelp-2.26.0.ebuild:
Marking yelp-2.26.0 ppc64 stable for bug 281427
diff --git a/gnome-extra/yelp/files/yelp-2.28.1-system-nspr.patch b/gnome-extra/yelp/files/yelp-2.28.1-system-nspr.patch
new file mode 100644
index 000000000000..1e37f4de7eec
--- /dev/null
+++ b/gnome-extra/yelp/files/yelp-2.28.1-system-nspr.patch
@@ -0,0 +1,15 @@
+Include nspr cflags to prevent build failure
+
+https://bugs.gentoo.org/295016
+
+---
+--- configure.in
++++ configure.in
+@@ -78,6 +78,7 @@
+ libstartup-notification-1.0 >= 0.8
+ dbus-glib-1
+ rarian >= 0.7.0
++ nspr >= 4.7.4
+ ])
+ AC_SUBST([YELP_CFLAGS])
+ AC_SUBST([YELP_LIBS])
diff --git a/gnome-extra/yelp/yelp-2.28.1-r1.ebuild b/gnome-extra/yelp/yelp-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..712543b20516
--- /dev/null
+++ b/gnome-extra/yelp/yelp-2.28.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.28.1-r1.ebuild,v 1.1 2009/12/24 16:49:21 nirbheek Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="beagle lzma"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=app-text/gnome-doc-utils-0.17.2
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.6.5
+ >=dev-libs/libxslt-1.1.4
+ >=x11-libs/startup-notification-0.8
+ >=dev-libs/dbus-glib-0.71
+ beagle? ( || (
+ >=dev-libs/libbeagle-0.3.0
+ =app-misc/beagle-0.2* ) )
+ net-libs/xulrunner:1.9
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( || (
+ app-arch/xz-utils
+ app-arch/lzma-utils ) )
+ >=app-text/rarian-0.7
+ >=app-text/scrollkeeper-9999"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common"
+# If eautoreconf:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gecko=libxul-embedding
+ $(use_enable lzma)"
+
+ if use beagle; then
+ G2CONF="${G2CONF} --with-search=beagle"
+ else
+ G2CONF="${G2CONF} --with-search=basic"
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix automagic lzma support, bug #266128
+ epatch "${FILESDIR}/${PN}-2.26.0-automagic-lzma.patch"
+
+ # Fix build with xulrunner-1.9.2
+ epatch "${FILESDIR}/${PN}-2.28.1-system-nspr.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # strip stupid options in configure, see bug #196621
+ sed -i 's|$AM_CFLAGS -pedantic -ansi|$AM_CFLAGS|' configure || die "sed failed"
+}