summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-03-14 22:46:07 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-03-14 22:46:07 +0000
commit8fedf479926dfabc87fa72b128f81aa3b0fe64f0 (patch)
treee8fb2a32462110df78fb0c1212e43e822724e9d5 /gnome-extra
parentx11-drivers/xf86-video-intel: xineramaproto is still needed for the 2.10 branch (diff)
downloadgentoo-2-8fedf479926dfabc87fa72b128f81aa3b0fe64f0.tar.gz
gentoo-2-8fedf479926dfabc87fa72b128f81aa3b0fe64f0.tar.bz2
gentoo-2-8fedf479926dfabc87fa72b128f81aa3b0fe64f0.zip
Version bump. Bug fixes and translation update.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog8
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.28.3.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 1cbe40ec14f7..b2e9d87f2151 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.111 2010/02/24 22:49:07 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.112 2010/03/14 22:46:07 eva Exp $
+
+*evolution-exchange-2.28.3 (14 Mar 2010)
+
+ 14 Mar 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +evolution-exchange-2.28.3.ebuild:
+ Version bump. Bug fixes and translation update.
24 Feb 2010; Gilles Dartiguelongue <eva@gentoo.org>
-files/evolution-exchange-2.22.3-addressbook-crash.patch,
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.28.3.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.28.3.ebuild
new file mode 100644
index 000000000000..a85d21ed3fd4
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.28.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.28.3.ebuild,v 1.1 2010/03/14 22:46:07 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-openldap
+ --disable-static
+ $(use_with debug e2k-debug)
+ $(use_with static static-ldap)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix build with --as-needed, upstream bug #597489
+ epatch "${FILESDIR}/${PN}-2.28.0-as-needed.patch"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}