summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:11:04 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:11:04 +0000
commit89d0416a9557ddf85c5b874115e8ffc60879baaf (patch)
tree1fbb9498d42faac4b57a2d8d4bc058e29cf9e7d7 /gnome-extra
parentgnome 2.16 (diff)
downloadgentoo-2-89d0416a9557ddf85c5b874115e8ffc60879baaf.tar.gz
gentoo-2-89d0416a9557ddf85c5b874115e8ffc60879baaf.tar.bz2
gentoo-2-89d0416a9557ddf85c5b874115e8ffc60879baaf.zip
gnome 2.16
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog12
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-1.8.0.ebuild139
-rw-r--r--gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.03
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-exchange-storage.patch30
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-libdb.patch13
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.7.4-move-subdirs.patch14
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.8.0-camel-rewind.patch11
7 files changed, 221 insertions, 1 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 03243e89f8b8..44df0fa46790 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.91 2006/09/06 05:25:54 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.92 2006/09/07 04:11:04 dang Exp $
+
+*evolution-data-server-1.8.0 (07 Sep 2006)
+
+ 07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evolution-data-server-1.7.3-exchange-storage.patch,
+ +files/evolution-data-server-1.7.3-libdb.patch,
+ +files/evolution-data-server-1.7.4-move-subdirs.patch,
+ +files/evolution-data-server-1.8.0-camel-rewind.patch,
+ +evolution-data-server-1.8.0.ebuild:
+ New version for gnome 2.16
06 Sep 2006; Joshua Kinard <kumba@gentoo.org>
evolution-data-server-1.4.2.1.ebuild, evolution-data-server-1.6.2.ebuild:
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-1.8.0.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-1.8.0.ebuild
new file mode 100644
index 000000000000..52fcf96d399a
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-1.8.0.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-1.8.0.ebuild,v 1.1 2006/09/07 04:11:04 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ipv6 kerberos krb4 ldap nntp ssl"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libbonobo-2.4.2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/gnome-common-2
+ gnome-base/gnome-keyring
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.2.90
+ sys-libs/zlib
+ =sys-libs/db-4*
+ ldap? ( >=net-nds/openldap-2.0 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ G2CONF="$(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable nntp) \
+ --with-libdb=/usr/$(get_libdir)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix broken libdb build
+ epatch "${FILESDIR}"/${PN}-1.7.3-libdb.patch
+
+ # Resolve symbols at execution time for setgid binaries
+ epatch "${FILESDIR}"/${PN}-no_lazy_bindings.patch
+
+ # exchange-storage --as-needed fixes
+ epatch "${FILESDIR}"/${PN}-1.7.3-exchange-storage.patch
+ epatch "${FILESDIR}"/${PN}-1.7.4-move-subdirs.patch
+
+ # Rewind in camel-disco-diary to fix a crash
+ epatch "${FILESDIR}"/${PN}-1.8.0-camel-rewind.patch
+
+#-------------Upstream GNOME look here -----------------#
+
+ # fix for dep ordering so we can add libedataserverui to libexchange-storage
+ # we need to do this or: undefined reference to `e_passwords_get_password'
+ # are the kinds of errors you will get.
+
+ # move the groupwise backend and provider for addressbook, camel, and
+ # calendar to its own folder called server.deps.
+ mkdir server.deps
+ mv addressbook/backends/groupwise server.deps/addressbook
+ mv camel/providers/groupwise server.deps/camel
+ mv calendar/backends/groupwise server.deps/calendar
+
+ # now fix the autotools foo for the new directory and the removed ones
+ echo "SUBDIRS = addressbook camel calendar" > server.deps/Makefile.am
+
+ # remove groupwise folder from Makefile's since they are in a diff location
+ sed -i -e 's: groupwise::' addressbook/backends/Makefile.am camel/providers/Makefile.am calendar/backends/Makefile.am
+
+ # fix configure.in location of the Makefile's
+ sed -i -e 's:addressbook/backends/groupwise:server.deps/addressbook:' configure.in
+ sed -i -e 's:camel/providers/groupwise:server.deps/camel:' configure.in
+ # tack on the server.deps Makefile on our last edit
+ sed -i -e 's:calendar/backends/groupwise:server.deps/calendar/Makefile\nserver.deps:' configure.in
+
+ # fix file includes
+ sed -i -e 's:<backends/groupwise/e-book-backend-groupwise.h>:"server.deps/addressbook/e-book-backend-groupwise.h":' addressbook/libedata-book/e-data-book-factory.c
+
+#---------------Upstream GNOME stop here---------------
+ eautoreconf
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ NSS_LIB=/usr/$(get_libdir)/nss
+ NSS_INC=/usr/include/nss
+ NSPR_LIB=/usr/$(get_libdir)/nspr
+ NSPR_INC=/usr/include/nspr
+
+ G2CONF="${G2CONF} \
+ --with-nspr-includes=${NSPR_INC} \
+ --with-nspr-libs=${NSPR_LIB} \
+ --with-nss-includes=${NSS_INC} \
+ --with-nss-libs=${NSS_LIB}"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ cd "${S}"
+ gnome2_src_compile
+}
diff --git a/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.0 b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.0
new file mode 100644
index 000000000000..1418ca96824a
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.0
@@ -0,0 +1,3 @@
+MD5 53f0885731440cb9cf0ca0601dd2105f evolution-data-server-1.8.0.tar.bz2 7128368
+RMD160 5f6439972760aa7e023247bdd8eff0826bda373c evolution-data-server-1.8.0.tar.bz2 7128368
+SHA256 c350351b80776155cacfe960ea6b219d7ef5160ea7378bc0d5d46851c0598637 evolution-data-server-1.8.0.tar.bz2 7128368
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-exchange-storage.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-exchange-storage.patch
new file mode 100644
index 000000000000..bf0fe7a56dee
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-exchange-storage.patch
@@ -0,0 +1,30 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-data-server-1.7.3.orig/configure.in evolution-data-server-1.7.3/configure.in
+--- evolution-data-server-1.7.3.orig/configure.in 2006-06-12 10:27:29.000000000 -0400
++++ evolution-data-server-1.7.3/configure.in 2006-07-07 10:22:49.000000000 -0400
+@@ -950,19 +950,23 @@
+ msg_krb5="no"
+ if test "x${with_krb5}" != "xno"; then
+ LDFLAGS_save="$LDFLAGS"
++ SAVE_LIBS="$LIBS"
+
+ mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
+ heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
+ AC_CACHE_CHECK([for Kerberos 5], ac_cv_lib_kerberos5,
+ [
+- LDFLAGS="$LDFLAGS -L$with_krb5_libs $mitlibs"
++ LDFLAGS="$LDFLAGS -L$with_krb5_libs"
++ LIBS="$SAVE_LIBS $mitlibs"
+ AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$mitlibs",
+ [
+- LDFLAGS="$LDFLAGS_save -L$with_krb5_libs $heimlibs"
++ LDFLAGS="$LDFLAGS_save -L$with_krb5_libs"
++ LIBS="$SAVE_LIBS $heimlibs"
+ AC_TRY_LINK_FUNC(krb5_init_context, ac_cv_lib_kerberos5="$heimlibs", ac_cv_lib_kerberos5="no")
+ ])
+- LDFLAGS="$LDFLAGS_save"
+ ])
++ LDFLAGS="$LDFLAGS_save"
++ LIBS="$SAVE_LIBS"
+ if test "$ac_cv_lib_kerberos5" != "no"; then
+ AC_DEFINE(HAVE_KRB5,1,[Define if you have Krb5])
+ if test "$ac_cv_lib_kerberos5" = "$mitlibs"; then
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-libdb.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-libdb.patch
new file mode 100644
index 000000000000..22ce75d2ffe6
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.3-libdb.patch
@@ -0,0 +1,13 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-data-server-1.7.3.orig/configure.in evolution-data-server-1.7.3/configure.in
+--- evolution-data-server-1.7.3.orig/configure.in 2006-06-12 10:27:29.000000000 -0400
++++ evolution-data-server-1.7.3/configure.in 2006-07-06 23:43:43.000000000 -0400
+@@ -1389,9 +1393,6 @@
+ export privincludedir
+ export privdatadir
+ AC_CONFIG_SUBDIRS(calendar/libical)
+-if test $dynamic_libdb = no; then
+- AC_CONFIG_SUBDIRS(libdb/dist)
+-fi
+ AC_OUTPUT([
+ Makefile
+ evolution-data-server-zip
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.4-move-subdirs.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.4-move-subdirs.patch
new file mode 100644
index 000000000000..13fc81a19dcb
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.7.4-move-subdirs.patch
@@ -0,0 +1,14 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-data-server-1.7.4.orig/Makefile.am evolution-data-server-1.7.4/Makefile.am
+--- evolution-data-server-1.7.4.orig/Makefile.am 2006-04-24 06:39:59.000000000 -0400
++++ evolution-data-server-1.7.4/Makefile.am 2006-07-20 18:15:50.000000000 -0400
+@@ -5,8 +5,8 @@
+ LIBDB = libdb
+ endif
+
+-SUBDIRS = $(LIBDB) win32 libedataserver servers camel addressbook calendar libedataserverui src docs art po
+-DIST_SUBDIRS= win32 libedataserver servers camel addressbook calendar libedataserverui src docs art po
++SUBDIRS = $(LIBDB) win32 libedataserver camel addressbook calendar libedataserverui servers server.deps src docs art po
++DIST_SUBDIRS= win32 libedataserver camel addressbook calendar libedataserverui servers server.deps src docs art po
+
+ changelogs = \
+ ChangeLog
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.8.0-camel-rewind.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.8.0-camel-rewind.patch
new file mode 100644
index 000000000000..c420759a8950
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.8.0-camel-rewind.patch
@@ -0,0 +1,11 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-data-server-1.7.90.1.orig/camel/camel-disco-diary.c evolution-data-server-1.7.90.1/camel/camel-disco-diary.c
+--- evolution-data-server-1.7.90.1.orig/camel/camel-disco-diary.c 2006-02-16 04:36:28.000000000 -0500
++++ evolution-data-server-1.7.90.1/camel/camel-disco-diary.c 2006-08-01 22:55:43.000000000 -0400
+@@ -404,6 +404,7 @@
+
+ /* Truncate the log */
+ ftruncate (fileno (diary->file), 0);
++ rewind (diary->file);
+ }
+
+ CamelDiscoDiary *