summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-19 20:07:20 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-19 20:07:20 +0000
commit3b6a79c52fd9b2deab7e2f3c0137891fb11f7552 (patch)
tree9375d3b0c6ebe44e5c5cf46ece4985d8606ad85c /gnome-extra/hamster-applet/files
parentBump sys-cluster/openmpi-1.2.8 (diff)
downloadgentoo-2-3b6a79c52fd9b2deab7e2f3c0137891fb11f7552.tar.gz
gentoo-2-3b6a79c52fd9b2deab7e2f3c0137891fb11f7552.tar.bz2
gentoo-2-3b6a79c52fd9b2deab7e2f3c0137891fb11f7552.zip
initial ebuild, Shamelessly stolen from graaff's overlay.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra/hamster-applet/files')
-rw-r--r--gnome-extra/hamster-applet/files/hamster-applet-2.24.0-gnomevfs.patch22
-rw-r--r--gnome-extra/hamster-applet/files/hamster-applet-2.24.0-python25.patch69
2 files changed, 91 insertions, 0 deletions
diff --git a/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-gnomevfs.patch b/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-gnomevfs.patch
new file mode 100644
index 000000000000..731bc8b3d058
--- /dev/null
+++ b/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-gnomevfs.patch
@@ -0,0 +1,22 @@
+diff -Naur hamster-applet-2.24.0/hamster/about.py hamster-applet-2.24.0.new/hamster/about.py
+--- hamster-applet-2.24.0/hamster/about.py 2008-09-22 22:20:02.000000000 +0530
++++ hamster-applet-2.24.0.new/hamster/about.py 2008-09-29 09:10:13.000000000 +0530
+@@ -21,15 +21,15 @@
+ from os.path import join
+ from hamster import SHARED_DATA_DIR
+ from hamster.defs import VERSION
+-import gtk, gnomevfs
++import gtk
+ import hamster
+
+
+ def on_email(about, mail):
+- gnomevfs.url_show("mailto:%s" % mail)
++ gtk.show_uri(gtk.gdk.Screen(), "mailto:%s" % mail, 0L)
+
+ def on_url(about, link):
+- gnomevfs.url_show(link)
++ gtk.show_uri(gtk.gdk.Screen(), link, 0L)
+
+ gtk.about_dialog_set_email_hook(on_email)
+ gtk.about_dialog_set_url_hook(on_url)
diff --git a/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-python25.patch b/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-python25.patch
new file mode 100644
index 000000000000..335389e8b0cd
--- /dev/null
+++ b/gnome-extra/hamster-applet/files/hamster-applet-2.24.0-python25.patch
@@ -0,0 +1,69 @@
+diff -Naur hamster-applet-2.24.0.orig/configure.ac hamster-applet-2.24.0/configure.ac
+--- hamster-applet-2.24.0.orig/configure.ac 2008-09-22 22:20:03.000000000 +0530
++++ hamster-applet-2.24.0/configure.ac 2008-09-26 15:46:37.000000000 +0530
+@@ -100,20 +100,38 @@
+ AC_MSG_RESULT($PYGTK_DEFSDIR)
+
+
+-AC_MSG_CHECKING([for pysqlite2 module])
+-if AC_RUN_LOG([DISPLAY= $PYTHON -c '
++if test "x$PYTHON_VERSION" = "x2.5"; then
++ AC_MSG_CHECKING([for python sqlite module])
++ if AC_RUN_LOG([DISPLAY= $PYTHON -c '
++try:
++ import sqlite3
++except ImportError, e:
++ if str(e).find("sqlite3") >= 0:
++ raise
++except:
++ pass
++ ']); then
++ AC_MSG_RESULT([yes])
++ else
++ AC_MSG_RESULT([no])
++ AC_MSG_ERROR([Python 2.5: inbuilt sqlite is required to build hamster])
++ fi
++else
++ AC_MSG_CHECKING([for pysqlite2 module])
++ if AC_RUN_LOG([DISPLAY= $PYTHON -c '
+ try:
+ import pysqlite2
+ except ImportError, e:
+ if str(e).find("pysqlite2") >= 0:
+- raise
++ raise
+ except:
+ pass
+-']); then
+- AC_MSG_RESULT([yes])
+-else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([pysqlite2 Python module required to build hamster])
++ ']); then
++ AC_MSG_RESULT([yes])
++ else
++ AC_MSG_RESULT([no])
++ AC_MSG_ERROR([Python 2.4: pysqlite2 module required to build hamster])
++ fi
+ fi
+
+
+diff -Naur hamster-applet-2.24.0.orig/hamster/db.py hamster-applet-2.24.0/hamster/db.py
+--- hamster-applet-2.24.0.orig/hamster/db.py 2008-09-22 22:20:02.000000000 +0530
++++ hamster-applet-2.24.0/hamster/db.py 2008-09-26 16:05:58.000000000 +0530
+@@ -21,7 +21,14 @@
+
+ """separate file for database operations"""
+
+-from pysqlite2 import dbapi2 as sqlite
++try:
++ import sqlite3 as sqlite
++except ImportError:
++ try:
++ from pysqlite2 import dbapi2 as sqlite
++ except ImportError:
++ print "Error: Neither sqlite3 nor pysqlite2 found"
++ raise
+ import os, time
+ import datetime
+ import hamster