summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-17 00:10:07 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-17 00:10:07 +0000
commit88e3134de98e27f9f0a42df87ad9034b3b79777b (patch)
tree6ab93acbfc9b97036d9589a9d011ebdf64bee020 /gnome-extra/gtkhtml
parentPatch bug fixed (diff)
downloadgentoo-2-88e3134de98e27f9f0a42df87ad9034b3b79777b.tar.gz
gentoo-2-88e3134de98e27f9f0a42df87ad9034b3b79777b.tar.bz2
gentoo-2-88e3134de98e27f9f0a42df87ad9034b3b79777b.zip
Update, thanks quacks
A D A A A A A A A A A A
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/files/digest-gtkhtml-0.9.21
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-0.9.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/files/digest-gtkhtml-0.9.2 b/gnome-extra/gtkhtml/files/digest-gtkhtml-0.9.2
new file mode 100644
index 000000000000..6f6a2a51211a
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/digest-gtkhtml-0.9.2
@@ -0,0 +1 @@
+MD5 538bd169b875a06d68be74fe7176a8f7 gtkhtml-0.9.2.tar.gz
diff --git a/gnome-extra/gtkhtml/gtkhtml-0.9.2.ebuild b/gnome-extra/gtkhtml/gtkhtml-0.9.2.ebuild
new file mode 100644
index 000000000000..c5a82dfd0e26
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-0.9.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-0.9.2.ebuild,v 1.1 2001/05/17 00:10:07 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtkhtml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/gtkhtml/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gal-0.5
+ >=gnome-base/gconf-1.0
+ >=gnome-base/control-center-1.2.4
+ >=gnome-base/glibwww-0.2-r1
+ >=gnome-base/libghttp-1.0.9"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# patch -p1 < ${FILESDIR}/${P}-gentoo.diff
+# try aclocal -I macros
+# try autoconf
+ try automake
+}
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="${myconf} --with-bonobo"
+ else
+ myconf="${myconf} --without-bonobo"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome ${myconf} --with-gconf
+
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ #insinto /opt/gnome/include/gtkhtml
+ #doins src/htmlurl.h
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+
+}
+
+
+
+
+
+
+
+
+
+
+
+
+