summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:11:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:11:28 +0000
commit53de5691235fc622c9a64bf65eda36ed32a40c49 (patch)
tree1e117373180772f6c78ca86dd676355a63759105 /gnome-extra/gnome-boxes
parentVersion bump for Gnome 3.12. Move flags manipulation to configure where it be... (diff)
downloadgentoo-2-53de5691235fc622c9a64bf65eda36ed32a40c49.tar.gz
gentoo-2-53de5691235fc622c9a64bf65eda36ed32a40c49.tar.bz2
gentoo-2-53de5691235fc622c9a64bf65eda36ed32a40c49.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/ChangeLog8
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.12.1.ebuild92
2 files changed, 99 insertions, 1 deletions
diff --git a/gnome-extra/gnome-boxes/ChangeLog b/gnome-extra/gnome-boxes/ChangeLog
index 47bd3a2ba715..404f2b62d023 100644
--- a/gnome-extra/gnome-boxes/ChangeLog
+++ b/gnome-extra/gnome-boxes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-boxes
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/ChangeLog,v 1.4 2014/03/09 10:49:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/ChangeLog,v 1.5 2014/04/27 17:11:28 eva Exp $
+
+*gnome-boxes-3.12.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-boxes-3.12.1.ebuild:
+ Version bump for Gnome 3.12.
09 Mar 2014; Pacho Ramos <pacho@gentoo.org> gnome-boxes-3.10.2.ebuild:
amd64 stable, bug 499954
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.12.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.12.1.ebuild
new file mode 100644
index 000000000000..1195778a8325
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.12.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/gnome-boxes-3.12.1.ebuild,v 1.1 2014/04/27 17:11:28 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit linux-info gnome2 vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due licenses from gnome-boxes-nonfree
+IUSE="smartcard usbredir" #bindist
+KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.9
+ >=app-emulation/qemu-1.3.1[spice,smartcard?,usbredir?]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.1.7
+ >=x11-libs/gtk+-3.11:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.16[gtk3,smartcard?,usbredir?]
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools
+ >=virtual/udev-165[gudev]
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ linux_config_exists
+
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe)
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ $(use_enable usbredir) \
+ $(use_enable smartcard) \
+ --enable-ovirt=no
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Before running gnome-boxes, you will need to load the KVM modules"
+ elog "If you have an Intel Processor, run:"
+ elog " modprobe kvm-intel"
+ einfo
+ elog "If you have an AMD Processor, run:"
+ elog " modprobe kvm-amd"
+}