summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-27 11:41:14 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-27 11:41:14 +0000
commitf6301d5b2d8ef2c8ece68c1b16cfbcbc8cb34f49 (patch)
treeea7c2fe0709e32e352d95a10837dbdb400861e6c /gnome-base
parentStable on amd64 wrt bug #372989 (diff)
downloadgentoo-2-f6301d5b2d8ef2c8ece68c1b16cfbcbc8cb34f49.tar.gz
gentoo-2-f6301d5b2d8ef2c8ece68c1b16cfbcbc8cb34f49.tar.bz2
gentoo-2-f6301d5b2d8ef2c8ece68c1b16cfbcbc8cb34f49.zip
Apply patch fixing renaming issues with afc backend, allow to build without udev on prefix (bug #293480 by Rabbe Fogelholm).
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog9
-rw-r--r--gnome-base/gvfs/files/gvfs-1.6.7-fix-renaming.patch46
-rw-r--r--gnome-base/gvfs/gvfs-1.6.7-r1.ebuild119
3 files changed, 173 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 0c28be86ec1b..054a407c8871 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.144 2011/06/09 00:59:10 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.145 2011/06/27 11:41:14 pacho Exp $
+
+*gvfs-1.6.7-r1 (27 Jun 2011)
+
+ 27 Jun 2011; Pacho Ramos <pacho@gentoo.org> +gvfs-1.6.7-r1.ebuild,
+ +files/gvfs-1.6.7-fix-renaming.patch:
+ Apply patch fixing renaming issues with afc backend, allow to build without
+ udev on prefix (bug #293480 by Rabbe Fogelholm).
09 Jun 2011; Sebastian Pipping <sping@gentoo.org> gvfs-1.6.7.ebuild:
Add >=sys-fs/udev-171[gudev] as an alternative dependency to
diff --git a/gnome-base/gvfs/files/gvfs-1.6.7-fix-renaming.patch b/gnome-base/gvfs/files/gvfs-1.6.7-fix-renaming.patch
new file mode 100644
index 000000000000..6fff4d6843d5
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.6.7-fix-renaming.patch
@@ -0,0 +1,46 @@
+From 6282ea2d0aebf0692aca8de22f8733d1ec109711 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Thu, 24 Mar 2011 11:46:32 +0000
+Subject: afc: Fix renaming files moving them to the root dir
+
+We were moving and renaming files, instead of just renaming them,
+as the display_name wasn't properly rooted to the existing directory.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=638191
+---
+diff --git a/daemon/gvfsbackendafc.c b/daemon/gvfsbackendafc.c
+index ae266c4..0379847 100644
+--- a/daemon/gvfsbackendafc.c
++++ b/daemon/gvfsbackendafc.c
+@@ -1386,19 +1386,28 @@ g_vfs_backend_afc_set_display_name (GVfsBackend *backend,
+ const char *display_name)
+ {
+ GVfsBackendAfc *self;
++ char *new_path;
++ char *dirname;
+
+ self = G_VFS_BACKEND_AFC(backend);
+ g_return_if_fail (self->connected);
+
++ dirname = g_path_get_dirname (filename);
++ new_path = g_build_filename (dirname, display_name, NULL);
++ g_free (dirname);
++
+ if (G_UNLIKELY(g_vfs_backend_afc_check (afc_rename_path (self->afc_cli,
+- filename, display_name),
++ filename, new_path),
+ G_VFS_JOB(job))))
+ {
++ g_free (new_path);
+ return;
+ }
+
+ g_vfs_job_set_display_name_set_new_path (job, display_name);
+
++ g_free (new_path);
++
+ g_vfs_job_succeeded (G_VFS_JOB(job));
+ }
+
+--
+cgit v0.9
diff --git a/gnome-base/gvfs/gvfs-1.6.7-r1.ebuild b/gnome-base/gvfs/gvfs-1.6.7-r1.ebuild
new file mode 100644
index 000000000000..9d281788ca58
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.6.7-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.6.7-r1.ebuild,v 1.1 2011/06/27 11:41:14 pacho Exp $
+
+EAPI="4"
+GNOME_TARBALL_SUFFIX="bz2"
+GCONF_DEBUG="no"
+
+inherit autotools bash-completion gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="archive avahi bluetooth cdda doc fuse gdu gnome gnome-keyring gphoto2 +http ios prefix samba +udev"
+
+RDEPEND=">=dev-libs/glib-2.23.4:2
+ >=sys-apps/dbus-1.0
+ dev-libs/libxml2
+ net-misc/openssh
+ !prefix? ( >=sys-fs/udev-138 )
+ archive? ( app-arch/libarchive )
+ avahi? ( >=net-dns/avahi-0.6 )
+ bluetooth? (
+ >=app-mobilephone/obex-data-server-0.4.5
+ dev-libs/dbus-glib
+ net-wireless/bluez
+ dev-libs/expat )
+ fuse? ( >=sys-fs/fuse-2.8.0 )
+ gdu? ( >=sys-apps/gnome-disk-utility-2.29 )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ gphoto2? ( >=media-libs/libgphoto2-2.4.7 )
+ ios? ( app-pda/libimobiledevice )
+ udev? (
+ cdda? ( >=dev-libs/libcdio-0.78.2[-minimal] )
+ || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
+ http? ( >=net-libs/libsoup-gnome-2.26.0 )
+ samba? ( || ( >=net-fs/samba-3.4.6[smbclient]
+ <=net-fs/samba-3.3 ) )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ if use cdda && ! use udev; then
+ ewarn
+ ewarn "You need to enable USE=\"udev\" for USE=\"cdda\" to be useful."
+ ewarn
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-hal
+ --disable-bash-completion
+ --with-dbus-service-dir=/usr/share/dbus-1/services
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gdu)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable ios afc)
+ $(use_enable udev gudev)
+ $(use_enable http)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)
+ $(use_enable !prefix udev)"
+
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Conditional patching purely to avoid eautoreconf
+ use gphoto2 && epatch "${FILESDIR}/${PN}-1.2.2-gphoto2-stricter-checks.patch"
+
+ if use archive; then
+ epatch "${FILESDIR}/${PN}-1.2.2-expose-archive-backend.patch"
+ echo "mount-archive.desktop.in" >> po/POTFILES.in
+ echo "mount-archive.desktop.in.in" >> po/POTFILES.in
+ fi
+
+ if use prefix; then
+ sed -i -e 's/gvfsd-burn/ /' daemon/Makefile.am || die
+ sed -i -e 's/burn.mount.in/ /' daemon/Makefile.am || die
+ sed -i -e 's/burn.mount/ /' daemon/Makefile.am || die
+ fi
+
+ { use gphoto2 || use archive || use prefix; } && eautoreconf
+
+ # Disable API deprecation
+ sed 's/-DG_DISABLE_DEPRECATED//' \
+ -i */*/Makefile.am */*/Makefile.in */Makefile.am */Makefile.in \
+ || die "sed failed"
+
+ # afc: Fix renaming files moving them to the root dir
+ epatch "${FILESDIR}/${P}-fix-renaming.patch"
+}
+
+src_install() {
+ gnome2_src_install
+ use bash-completion && \
+ dobashcompletion programs/gvfs-bash-completion.sh ${PN}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use bash-completion && bash-completion_pkg_postinst
+
+ ewarn "In order to use the new gvfs services, please reload dbus configuration"
+ ewarn "You may need to log out and log back in for some changes to take effect"
+}