summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 04:31:08 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 04:31:08 +0000
commit97207711437f382c4bc94412ab05ecf560b23066 (patch)
treec6d404e3d36a2290e477867efcee721c37ace9bb /gnome-base
parentbug 379899; honor portage dosym behaviour, rather than forcing breakage on us... (diff)
downloadgentoo-2-97207711437f382c4bc94412ab05ecf560b23066.tar.gz
gentoo-2-97207711437f382c4bc94412ab05ecf560b23066.tar.bz2
gentoo-2-97207711437f382c4bc94412ab05ecf560b23066.zip
Fix the fcaps() error message to take the running kernel version into account.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-keyring/ChangeLog7
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild11
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild11
3 files changed, 20 insertions, 9 deletions
diff --git a/gnome-base/gnome-keyring/ChangeLog b/gnome-base/gnome-keyring/ChangeLog
index 6d4c95f616bb..32d9008a017f 100644
--- a/gnome-base/gnome-keyring/ChangeLog
+++ b/gnome-base/gnome-keyring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-keyring
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.216 2011/11/18 03:40:54 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.217 2011/11/18 04:31:07 tetromino Exp $
+
+ 18 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-keyring-3.2.1.ebuild, gnome-keyring-3.2.2.ebuild:
+ Fix the fcaps() error message to take the running kernel version into
+ account.
18 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
gnome-keyring-3.2.1.ebuild, gnome-keyring-3.2.2.ebuild:
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
index f2e7fcca6119..2f723474a2a0 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild,v 1.2 2011/11/18 03:40:54 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild,v 1.3 2011/11/18 04:31:08 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit gnome2 multilib pam virtualx
+inherit gnome2 multilib pam versionator virtualx
DESCRIPTION="Password and keyring managing daemon"
HOMEPAGE="http://www.gnome.org/"
@@ -81,6 +81,7 @@ pkg_postinst() {
# @DESCRIPTION:
# fcaps sets the specified capabilities in the effective and permitted set of
# the given file. In case of failure fcaps sets the given file-mode.
+# Requires versionator.eclass
fcaps() {
local uid_gid=$1
local perms=$2
@@ -104,8 +105,10 @@ fcaps() {
ewarn "Failed to set capabilities. Probable reason is missing kernel support."
ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
ewarn "where <FS> is the filesystem to store ${path}"
- ewarn "If you are using kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
+ if ! version_is_at_least 2.6.32 "$(uname -r)"; then
+ ewarn "For kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
+ fi
ewarn
ewarn "Falling back to suid now..."
chmod u+s ${path}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
index 83e9113166db..e828df48a24a 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild,v 1.2 2011/11/18 03:40:54 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild,v 1.3 2011/11/18 04:31:07 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit gnome2 multilib pam virtualx
+inherit gnome2 multilib pam versionator virtualx
DESCRIPTION="Password and keyring managing daemon"
HOMEPAGE="http://www.gnome.org/"
@@ -83,6 +83,7 @@ pkg_postinst() {
# @DESCRIPTION:
# fcaps sets the specified capabilities in the effective and permitted set of
# the given file. In case of failure fcaps sets the given file-mode.
+# Requires versionator.eclass
fcaps() {
local uid_gid=$1
local perms=$2
@@ -106,8 +107,10 @@ fcaps() {
ewarn "Failed to set capabilities. Probable reason is missing kernel support."
ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
ewarn "where <FS> is the filesystem to store ${path}"
- ewarn "If you are using kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
+ if ! version_is_at_least 2.6.32 "$(uname -r)"; then
+ ewarn "For kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
+ fi
ewarn
ewarn "Falling back to suid now..."
chmod u+s ${path}