summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-11 19:15:50 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-11 19:15:50 +0000
commit82e304d26c7ac6459b71dee7ca06960d2778cea8 (patch)
treecf5872c318aa562bfbbc17480143cb7a7808d711 /gnome-base
parentUpdate metapackages to stop emerge world from continue installing old apps, o... (diff)
downloadgentoo-2-82e304d26c7ac6459b71dee7ca06960d2778cea8.tar.gz
gentoo-2-82e304d26c7ac6459b71dee7ca06960d2778cea8.tar.bz2
gentoo-2-82e304d26c7ac6459b71dee7ca06960d2778cea8.zip
Update metapackages to stop emerge world from continue installing old apps, obsolete fallback components and blocks
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-light/ChangeLog8
-rw-r--r--gnome-base/gnome-light/gnome-light-3.8.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/gnome-base/gnome-light/ChangeLog b/gnome-base/gnome-light/ChangeLog
index be21ff3f0d9f..bb89b3957093 100644
--- a/gnome-base/gnome-light/ChangeLog
+++ b/gnome-base/gnome-light/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-light
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.167 2013/03/07 08:35:04 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.168 2013/04/11 19:15:50 pacho Exp $
+
+*gnome-light-3.8.0 (11 Apr 2013)
+
+ 11 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gnome-light-3.8.0.ebuild:
+ Update metapackages to stop emerge world from continue installing old apps,
+ obsolete fallback components and blocks
07 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-light-3.4.1.ebuild:
diff --git a/gnome-base/gnome-light/gnome-light-3.8.0.ebuild b/gnome-base/gnome-light/gnome-light-3.8.0.ebuild
new file mode 100644
index 000000000000..ca98d72a1106
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/gnome-light-3.8.0.ebuild,v 1.1 2013/04/11 19:15:50 pacho Exp $
+
+EAPI="5"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+RDEPEND="!gnome-base/gnome
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-menus-${PV}:3
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV} )
+
+ >=x11-themes/gnome-icon-theme-${PV}
+ >=x11-themes/gnome-icon-theme-symbolic-${PV}
+ >=x11-themes/gnome-themes-standard-${PV}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.16.0"
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use e16, sawfish, etc
+ ewarn "You're installing neither GNOME Shell nor GNOME Fallback!"
+ ewarn "You will have to install and manage a window manager by yourself"
+ # https://bugs.gentoo.org/show_bug.cgi?id=303375
+ ewarn "See: <add link to docs about component handling in gnome-session>"
+ fi
+}