summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-31 22:14:38 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-31 22:14:38 +0000
commitcb66a209cebc4e5891b9814cfe8277a8ef7bc2c1 (patch)
treee6304bfd5bea0849424ad1229ba474c2df28481e /gnome-base/libglade
parentcleaned up (diff)
downloadgentoo-2-cb66a209cebc4e5891b9814cfe8277a8ef7bc2c1.tar.gz
gentoo-2-cb66a209cebc4e5891b9814cfe8277a8ef7bc2c1.tar.bz2
gentoo-2-cb66a209cebc4e5891b9814cfe8277a8ef7bc2c1.zip
cleaned up
Diffstat (limited to 'gnome-base/libglade')
-rw-r--r--gnome-base/libglade/libglade-0.16-r1.ebuild61
1 files changed, 28 insertions, 33 deletions
diff --git a/gnome-base/libglade/libglade-0.16-r1.ebuild b/gnome-base/libglade/libglade-0.16-r1.ebuild
index ee47e4f39a19..ae701ec33a13 100644
--- a/gnome-base/libglade/libglade-0.16-r1.ebuild
+++ b/gnome-base/libglade/libglade-0.16-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.16-r1.ebuild,v 1.4 2001/08/23 10:12:56 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.16-r1.ebuild,v 1.5 2001/08/31 22:11:27 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,43 +9,38 @@ DESCRIPTION="libglade"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND="nls? ( sys-devel/gettext )
- >=gnome-base/gnome-libs-1.2.12
- >=gnome-base/libxml-1.8.11
- bonobo2? ( >=gnome-base/bonobo-0.37 )"
+RDEPEND=">=gnome-base/gnome-libs-1.2.12
+ >=gnome-base/libxml-1.8.11
+ bonobo? ( >=gnome-base/bonobo-1.0.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_compile() {
+ local myopts
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo --disable-bonobotest"
+ else
+ myconf="--disable-bonobo"
+ fi
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
- local myopts
- if [ "`use bonobo2`" ]
- then
- # I had to add --disable-bonobotest, because, for some reason,
- # the conftest in configure segfaults, but libglade still
- # compiles and runs just fine... -- pete
- myconf="--enable-bonobo --disable-bonobotest"
- else
- myconf="--disable-bonobo"
- fi
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --disable-gnomedb ${myconf}
- try pmake
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --disable-gnomedb --mandir=/opt/gnome/man ${myconf}
+ assert
+ emake || die
}
src_install() {
- try make prefix=${D}/opt/gnome install
- dodoc AUTHORS COPYING* ChangeLog NEWS
- dodoc doc/*.txt
+ make prefix=${D}/opt/gnome install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
}
-
-
-
-
-
-
-
-
-