summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-04-22 20:25:19 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-04-22 20:25:19 +0000
commitc13ed4557352d48fee9fe4fc20e917ad52ef2b6c (patch)
treea0c9b4c97f85a6ed2e30da9d9562e51823268f6b /gnome-base/gconf
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-c13ed4557352d48fee9fe4fc20e917ad52ef2b6c.tar.gz
gentoo-2-c13ed4557352d48fee9fe4fc20e917ad52ef2b6c.tar.bz2
gentoo-2-c13ed4557352d48fee9fe4fc20e917ad52ef2b6c.zip
Patch that resolves C syntax problems. Closes bug #48670.
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog12
-rw-r--r--gnome-base/gconf/files/GConf-2.6.1-gcc2_fix.patch11
-rw-r--r--gnome-base/gconf/files/gconf-2.2.1-stdio.patch11
-rw-r--r--gnome-base/gconf/gconf-2.6.1.ebuild12
4 files changed, 32 insertions, 14 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 9d3670add727..56f2485db200 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.64 2004/03/31 07:53:03 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.65 2004/04/22 20:25:19 leonardop Exp $
+
+ 22 Apr 2004; L. Boshell <leonardop@gentoo.org> gconf-2.6.1.ebuild,
+ files/GConf-2.6.1-gcc2_fix.patch:
+ Added patch to remove syntax problems, causing compilation to fail under
+ gcc-2. Resolves bug #48670, thanks to Tristan Henderson.
+
+*gconf-2.6.1 (20 Apr 2004)
+
+ 20 Apr 2004; foser <foser@gentoo.org> gconf-2.6.1.ebuild :
+ Version bump.
31 Mar 2004; L. Boshell <leonardop@gentoo.org> gconf-2.4.0.1.ebuild:
Added DEPEND entry for =app-text/docbook-sgml-dtd-3.0* if the `doc' USE
diff --git a/gnome-base/gconf/files/GConf-2.6.1-gcc2_fix.patch b/gnome-base/gconf/files/GConf-2.6.1-gcc2_fix.patch
new file mode 100644
index 000000000000..ce8f5b78866d
--- /dev/null
+++ b/gnome-base/gconf/files/GConf-2.6.1-gcc2_fix.patch
@@ -0,0 +1,11 @@
+diff -NurdB GConf-2.6.1-orig/gconf/gconf-internals.c GConf-2.6.1/gconf/gconf-internals.c
+--- GConf-2.6.1-orig/gconf/gconf-internals.c 2004-04-22 14:47:51.000000000 -0500
++++ GConf-2.6.1/gconf/gconf-internals.c 2004-04-22 14:49:30.000000000 -0500
+@@ -2839,7 +2839,6 @@
+ GError **error)
+ {
+ ConfigServer server = CORBA_OBJECT_NIL;
+-;
+ int p[2] = { -1, -1 };
+ char buf[1];
+ GError *tmp_err;
diff --git a/gnome-base/gconf/files/gconf-2.2.1-stdio.patch b/gnome-base/gconf/files/gconf-2.2.1-stdio.patch
deleted file mode 100644
index 9e72b0b6e4ff..000000000000
--- a/gnome-base/gconf/files/gconf-2.2.1-stdio.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -NurB GConf-2.2.1-orig/backends/markup-tree.c GConf-2.2.1/backends/markup-tree.c
---- GConf-2.2.1-orig/backends/markup-tree.c 2003-11-12 22:13:09.000000000 -0500
-+++ GConf-2.2.1/backends/markup-tree.c 2003-11-12 22:14:09.000000000 -0500
-@@ -31,6 +31,7 @@
- #include <dirent.h>
- #include <limits.h>
- #include <time.h>
-+#include <stdio.h>
-
- typedef struct
- {
diff --git a/gnome-base/gconf/gconf-2.6.1.ebuild b/gnome-base/gconf/gconf-2.6.1.ebuild
index ecee0fc46243..a39a4e8504a2 100644
--- a/gnome-base/gconf/gconf-2.6.1.ebuild
+++ b/gnome-base/gconf/gconf-2.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.1 2004/04/20 23:10:23 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.2 2004/04/22 20:25:19 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
MY_PN=GConf
MY_P=${MY_PN}-${PV}
@@ -32,6 +32,14 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Remove invalid C syntax. See bug #48670.
+ epatch ${FILESDIR}/${MY_P}-gcc2_fix.patch
+}
+
src_install() {
gnome2_src_install