summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-04 08:20:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-04 08:20:12 +0000
commitb8f76ed85428a1221f05adccc9a0df15a57bc449 (patch)
treed7072139f4074cb655a25a44982e1b3f3a2ad64b /games-util
parentFixed glib issue, bug #318569. (diff)
downloadgentoo-2-b8f76ed85428a1221f05adccc9a0df15a57bc449.tar.gz
gentoo-2-b8f76ed85428a1221f05adccc9a0df15a57bc449.tar.bz2
gentoo-2-b8f76ed85428a1221f05adccc9a0df15a57bc449.zip
Fix overflow. Bug #337889
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/ucon64/ChangeLog8
-rw-r--r--games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch20
-rw-r--r--games-util/ucon64/ucon64-2.0.0.ebuild6
3 files changed, 30 insertions, 4 deletions
diff --git a/games-util/ucon64/ChangeLog b/games-util/ucon64/ChangeLog
index bda39e9f9a70..b57548984443 100644
--- a/games-util/ucon64/ChangeLog
+++ b/games-util/ucon64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/ucon64
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ChangeLog,v 1.13 2009/12/30 15:32:37 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ChangeLog,v 1.14 2010/11/04 08:20:12 tupone Exp $
+
+ 04 Nov 2010; Tupone Alfredo <tupone@gentoo.org> ucon64-2.0.0.ebuild,
+ +files/ucon64-2.0.0-ovflfix.patch:
+ Fix overflow. Bug #337889 by flameeyes@gentoo.org
30 Dec 2009; Tupone Alfredo <tupone@gentoo.org> ucon64-2.0.0.ebuild:
EAPI=2 and not installing missing files. Bug #298670 by
diff --git a/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch b/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch
new file mode 100644
index 000000000000..0a1668f2d09f
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch
@@ -0,0 +1,20 @@
+--- backup/lynxit.c.old 2010-11-04 09:07:18.000000000 +0100
++++ backup/lynxit.c 2010-11-04 09:08:17.000000000 +0100
+@@ -561,7 +561,7 @@
+ return FALSE;
+ }
+
+- if (strcmp (header.magic, "LYNX") != 0)
++ if (memcmp (header.magic, "LYNX", sizeof(header.magic)) != 0)
+ {
+ MESSAGE (("ERROR : %s is not a lynx image\n", filename));
+ fclose (fp);
+@@ -682,7 +682,7 @@
+ #endif
+
+ memset (&header, 0, sizeof (st_lnx_header_t));
+- strcpy (header.magic, MAGIC_STRING);
++ memcpy (header.magic, MAGIC_STRING, sizeof(header.magic));
+ strcpy (header.cartname, cartname);
+ strcpy (header.manufname, manufname);
+ header.page_size_bank0 = cart_analyse (BANK0);
diff --git a/games-util/ucon64/ucon64-2.0.0.ebuild b/games-util/ucon64/ucon64-2.0.0.ebuild
index e7d344eb20c5..880d5f0ae4c5 100644
--- a/games-util/ucon64/ucon64-2.0.0.ebuild
+++ b/games-util/ucon64/ucon64-2.0.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ucon64-2.0.0.ebuild,v 1.8 2009/12/30 15:32:38 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ucon64-2.0.0.ebuild,v 1.9 2010/11/04 08:20:12 tupone Exp $
EAPI=2
+inherit eutils
DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
HOMEPAGE="http://ucon64.sourceforge.net/"
@@ -18,6 +19,7 @@ DEPEND=""
S=${WORKDIR}/${P}-src/src
src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch
sed -i \
-e "/^CFLAGS/s/-O3/${CFLAGS}/" \
-e "/^LDFLAGS/s/-s$/${LDFLAGS}/" \