summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-09-01 15:57:52 +0000
committerIan Delaney <idella4@gentoo.org>2013-09-01 15:57:52 +0000
commit5da1ad373ba370e7d0170c9845846eb8b0d272c7 (patch)
tree9dfa5aa042f3c9a294dd9cdc5df3de5315105787 /games-util/umodpack
parentFix for platforms without strndup, such as Darwin pre-Lion (diff)
downloadgentoo-2-5da1ad373ba370e7d0170c9845846eb8b0d272c7.tar.gz
gentoo-2-5da1ad373ba370e7d0170c9845846eb8b0d272c7.tar.bz2
gentoo-2-5da1ad373ba370e7d0170c9845846eb8b0d272c7.zip
revbump -> EAPI 5, add invocation of tests
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'games-util/umodpack')
-rw-r--r--games-util/umodpack/ChangeLog9
-rw-r--r--games-util/umodpack/umodpack-0.5_beta16-r2.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/games-util/umodpack/ChangeLog b/games-util/umodpack/ChangeLog
index d0017fcf609a..07d0dbf16f6e 100644
--- a/games-util/umodpack/ChangeLog
+++ b/games-util/umodpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/umodpack
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/umodpack/ChangeLog,v 1.12 2012/10/05 20:39:51 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/umodpack/ChangeLog,v 1.13 2013/09/01 15:57:52 idella4 Exp $
+
+*umodpack-0.5_beta16-r2 (01 Sep 2013)
+
+ 01 Sep 2013; Ian Delaney <idella4@gentoo.org> +umodpack-0.5_beta16-r2.ebuild:
+ revbump -> EAPI 5, add invocation of tests
05 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org>
umodpack-0.5_beta16-r1.ebuild:
diff --git a/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
new file mode 100644
index 000000000000..33b14dd78c4f
--- /dev/null
+++ b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild,v 1.1 2013/09/01 15:57:52 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module toolchain-funcs
+
+MY_P=${P/_beta/b}
+DESCRIPTION="portable and useful [un]packer for Unreal Tournament's Umod files"
+HOMEPAGE="http://www.oldunreal.com/wiki/index.php?title=UmodPack"
+SRC_URI="mirror://gentoo/${MY_P}-allinone.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+DEPEND="virtual/perl-IO-Compress
+ dev-perl/Archive-Zip
+ dev-perl/Tie-IxHash
+ tk? ( dev-perl/perl-tk )"
+
+S=${WORKDIR}/${MY_P}
+SRC_TEST="do parallel"
+
+src_prepare() {
+ # remove the stupid perl modules since we already installed em
+ rm -rf {Archive-Zip,Compress-Zlib,Tie-IxHash,Tk}* || die
+}
+
+src_compile() {
+ perl-module_src_compile
+
+ cd umr-0.3 || die
+ emake DEBUG=0 CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ mydoc="Changes"
+ perl-module_src_install
+ dobin umod umr-0.3/umr
+ if use tk ; then
+ dobin xumod
+ fi
+}