summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-11-05 06:33:47 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-11-05 06:33:47 +0000
commit6fc015235cf4ce543be4ad456ebd1478553f4ce8 (patch)
tree0f262c2455078636023c1c601c9b370aec3b6930 /games-util/loki_patch/loki_patch-20091105.ebuild
parenthiding loki_patch output isn't very helpful (diff)
downloadgentoo-2-6fc015235cf4ce543be4ad456ebd1478553f4ce8.tar.gz
gentoo-2-6fc015235cf4ce543be4ad456ebd1478553f4ce8.tar.bz2
gentoo-2-6fc015235cf4ce543be4ad456ebd1478553f4ce8.zip
Version bump, fixes bugs #251102 and #281440
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'games-util/loki_patch/loki_patch-20091105.ebuild')
-rw-r--r--games-util/loki_patch/loki_patch-20091105.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-util/loki_patch/loki_patch-20091105.ebuild b/games-util/loki_patch/loki_patch-20091105.ebuild
new file mode 100644
index 000000000000..22a711a5e2e0
--- /dev/null
+++ b/games-util/loki_patch/loki_patch-20091105.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20091105.ebuild,v 1.1 2009/11/05 06:33:46 nyhm Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Loki Software binary patch tool"
+HOMEPAGE="http://www.icculus.org/loki_setup/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/loki_setupdb-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=dev-util/xdelta-1*
+ dev-libs/libxml2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-patchdata.patch
+ cd loki_setupdb
+ eautoreconf
+ cd "${S}"/${PN}
+ eautoreconf
+}
+
+src_configure() {
+ cd loki_setupdb
+ econf
+ cd "${S}"/${PN}
+ econf
+}
+
+src_compile() {
+ emake -C loki_setupdb || die "emake loki_setupdb failed"
+ emake -C loki_patch || die "emake loki_patch failed"
+}
+
+src_install() {
+ cd ${PN}
+ dobin loki_patch make_patch || die "dobin failed"
+ dodoc CHANGES NOTES README TODO
+}