summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-06-15 18:20:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-06-15 18:20:23 +0000
commit34b6d15db2b785f1cedc0f52034ce2670636aed7 (patch)
tree88def8dfd3ae45f95c357dbbf3803ef0d389132b /games-strategy
parentUse enigmail-0.95.0 (diff)
downloadgentoo-2-34b6d15db2b785f1cedc0f52034ce2670636aed7.tar.gz
gentoo-2-34b6d15db2b785f1cedc0f52034ce2670636aed7.tar.bz2
gentoo-2-34b6d15db2b785f1cedc0f52034ce2670636aed7.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.2.53
-rw-r--r--games-strategy/wesnoth/wesnoth-1.2.5.ebuild96
3 files changed, 106 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index b62dd07222a0..e20a28d7b63d 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.91 2007/04/16 04:57:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.92 2007/06/15 18:20:23 mr_bones_ Exp $
+
+*wesnoth-1.2.5 (15 Jun 2007)
+
+ 15 Jun 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.2.5.ebuild:
+ version bump
*wesnoth-1.2.4 (16 Apr 2007)
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.2.5 b/games-strategy/wesnoth/files/digest-wesnoth-1.2.5
new file mode 100644
index 000000000000..a6d03f8d79e3
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.2.5
@@ -0,0 +1,3 @@
+MD5 40e00ac97680fb69499191c30f130774 wesnoth-1.2.5.tar.bz2 68758427
+RMD160 eeae92b801a3d3885b6647965537ff045d93d4a7 wesnoth-1.2.5.tar.bz2 68758427
+SHA256 8e1bcab7165bd5eaf8c1d2eef0fce03a8c81daf885983dc0fda68998100e8cd0 wesnoth-1.2.5.tar.bz2 68758427
diff --git a/games-strategy/wesnoth/wesnoth-1.2.5.ebuild b/games-strategy/wesnoth/wesnoth-1.2.5.ebuild
new file mode 100644
index 000000000000..0b261ac35217
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.2.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.2.5.ebuild,v 1.1 2007/06/15 18:20:23 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+RDEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (
+ x11-libs/libX11
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ nls? ( virtual/libintl )"
+# the configure script is broken and checks for freetype even if
+# it won't be used. until it's either patched out or upstream fixes
+# it, just make it a DEPEND.
+# reported by Miika Linnapuomi
+DEPEND="${RDEPEND}
+ dedicated? ( >=media-libs/freetype-2 )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer vorbis ; then
+ die "Please emerge media-libs/sdl-mixer with USE=vorbis"
+ fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge media-libs/sdl-image with USE=png"
+ fi
+ if ! built_with_use media-libs/libsdl X ; then
+ die "Please emerge media-libs/libsdl with USE=X"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-fribidi \
+ --with-localedir=/usr/share/locale \
+ --with-icondir=/usr/share/icons \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable nls dummy-locales) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}