summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-01 07:50:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-01 07:50:36 +0000
commit01a166a7cc078f1d480ca5e4a75a4b45c4c247f7 (patch)
tree0e65bd4c711749ce7bd2187adec05a7ad547eb37 /games-strategy
parentversion bump (diff)
downloadgentoo-2-01a166a7cc078f1d480ca5e4a75a4b45c4c247f7.tar.gz
gentoo-2-01a166a7cc078f1d480ca5e4a75a4b45c4c247f7.tar.bz2
gentoo-2-01a166a7cc078f1d480ca5e4a75a4b45c4c247f7.zip
version bump
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.51
-rw-r--r--games-strategy/wesnoth/wesnoth-0.5.ebuild40
4 files changed, 49 insertions, 3 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 8e9e720d5bf5..b0d5ba159fca 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.1 2003/10/22 21:21:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.2 2003/11/01 07:50:29 mr_bones_ Exp $
+
+*wesnoth-0.5 (31 Oct 2003)
+
+ 31 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.5.ebuild:
+ version bump
*wesnoth-0.4.8 (22 Oct 2003)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index c1dfcd34c140..14055e1a6348 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,6 @@
MD5 780c10b9072e511acd2797e086ddffc6 wesnoth-0.4.8.ebuild 1042
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 cfd57ea4f2b243739df6d419592647f7 ChangeLog 413
-MD5 4706bd6739fd1cf3346cd68ae7526f33 wesnoth-0.5.ebuild 1038
+MD5 0d289a8a320a670d9d7b2f84c1be35e7 ChangeLog 532
+MD5 42f4f503301a4c69f42bb36758232090 wesnoth-0.5.ebuild 1171
MD5 12449f4d45609424ab20eb79f5f77baf files/digest-wesnoth-0.4.8 66
MD5 906d61f6bd37904556d48a72fd3d7e7f files/digest-wesnoth-0.5 65
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.5 b/games-strategy/wesnoth/files/digest-wesnoth-0.5
new file mode 100644
index 000000000000..dafcb7cddd40
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.5
@@ -0,0 +1 @@
+MD5 ae926aa1966aa2e0108644c46faf899a wesnoth-0.5.tar.gz 10416089
diff --git a/games-strategy/wesnoth/wesnoth-0.5.ebuild b/games-strategy/wesnoth/wesnoth-0.5.ebuild
new file mode 100644
index 000000000000..8da9169e8d0e
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.5.ebuild,v 1.1 2003/11/01 07:50:29 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ virtual/x11"
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS} -DWESNOTH_PATH=\\\"${GAMES_DATADIR}/wesnoth\\\""
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin wesnoth || die "dogamesbin failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ dodir ${GAMES_DATADIR}/wesnoth || die "dodir failed"
+ cp -r data fonts images music sounds \
+ ${D}${GAMES_DATADIR}/wesnoth/ || die "cp failed"
+
+ # Tidy up the mess
+ find ${D}${GAMES_DATADIR} -type f -exec chmod a-x \{\} \;
+ find ${D} -name CVS | xargs rm -rf \{\} \;
+ find ${D} -name .cvsignore -exec rm -f \{\} \;
+
+ prepgamesdirs
+}