summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-09 08:50:16 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-09 08:50:16 +0000
commit3497b5906ebddffc8799ad1b3e6b95fb9b96b776 (patch)
treed74ca80721630e87333e57c89f675fd56248bc76 /games-strategy/triplea
parentVersion bump. (diff)
downloadgentoo-2-3497b5906ebddffc8799ad1b3e6b95fb9b96b776.tar.gz
gentoo-2-3497b5906ebddffc8799ad1b3e6b95fb9b96b776.tar.bz2
gentoo-2-3497b5906ebddffc8799ad1b3e6b95fb9b96b776.zip
Add junit to DEPEND to fix building with java-strict. Tests don't seem separable from rest of compile.
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-strategy/triplea')
-rw-r--r--games-strategy/triplea/ChangeLog6
-rw-r--r--games-strategy/triplea/triplea-0.9.0.2.ebuild4
2 files changed, 8 insertions, 2 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index 28a8fd2a1ced..8bb8564df1f7 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/triplea
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.29 2007/02/16 00:48:18 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.30 2007/05/09 08:50:16 caster Exp $
+
+ 09 May 2007; Vlastimil Babka <caster@gentoo.org> triplea-0.9.0.2.ebuild:
+ Add junit to DEPEND to fix building with java-strict. Tests don't seem
+ separable from rest of compile.
16 Feb 2007; Tristan Heaven <nyhm@gentoo.org> triplea-0.9.0.2.ebuild:
Fix from Arttu Valo for jdk-1.6, bug #164553
diff --git a/games-strategy/triplea/triplea-0.9.0.2.ebuild b/games-strategy/triplea/triplea-0.9.0.2.ebuild
index bf1635ab98b5..54890a5d5cdf 100644
--- a/games-strategy/triplea/triplea-0.9.0.2.ebuild
+++ b/games-strategy/triplea/triplea-0.9.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.9.0.2.ebuild,v 1.3 2007/02/16 00:48:18 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.9.0.2.ebuild,v 1.4 2007/05/09 08:50:16 caster Exp $
inherit eutils java-pkg-2 java-ant-2 versionator games
@@ -21,6 +21,7 @@ RDEPEND="=dev-java/jgoodies-looks-2*
DEPEND="${RDEPEND}
>=virtual/jdk-1.5
dev-java/ant
+ dev-java/junit
app-arch/unzip"
RDEPEND="${RDEPEND}
>=virtual/jre-1.5"
@@ -49,6 +50,7 @@ src_unpack() {
lib/commons-logging-1.1.jar
java-pkg_jar-from commons-codec commons-codec.jar \
lib/commons-codec-1.3.jar
+ java-pkg_jar-from --build-only junit
java-pkg_ensure-no-bundled-jars
}