summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-11-23 17:13:01 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-11-23 17:13:01 +0000
commiteed6b167c2bd8fcbf9421a51f44efe0edcacdfb5 (patch)
treef4d6b8f2a9c525fef3786726dffb98124811bf26 /games-strategy/megaglest-data
parentStable for amd64, wrt bug #442394 (diff)
downloadgentoo-2-eed6b167c2bd8fcbf9421a51f44efe0edcacdfb5.tar.gz
gentoo-2-eed6b167c2bd8fcbf9421a51f44efe0edcacdfb5.tar.bz2
gentoo-2-eed6b167c2bd8fcbf9421a51f44efe0edcacdfb5.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/megaglest-data')
-rw-r--r--games-strategy/megaglest-data/ChangeLog8
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.7.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/games-strategy/megaglest-data/ChangeLog b/games-strategy/megaglest-data/ChangeLog
index b66624e620c8..6c4a269df794 100644
--- a/games-strategy/megaglest-data/ChangeLog
+++ b/games-strategy/megaglest-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/megaglest-data
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.3 2012/11/14 17:10:49 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.4 2012/11/23 17:13:01 hasufell Exp $
+
+*megaglest-data-3.7.1 (23 Nov 2012)
+
+ 23 Nov 2012; Julian Ospald <hasufell@gentoo.org>
+ +megaglest-data-3.7.1.ebuild:
+ version bump
*megaglest-data-3.7.0 (14 Nov 2012)
diff --git a/games-strategy/megaglest-data/megaglest-data-3.7.1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.7.1.ebuild
new file mode 100644
index 000000000000..f7ab69c50e1d
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/megaglest-data-3.7.1.ebuild,v 1.1 2012/11/23 17:13:01 hasufell Exp $
+
+EAPI=4
+inherit cmake-utils games
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.xz"
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="~games-strategy/megaglest-${PV}"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEGAGLEST_BIN_INSTALL_PATH="${GAMES_BINDIR}"
+ -DMEGAGLEST_DATA_INSTALL_PATH="${GAMES_DATADIR}/${MY_PN}"
+ -DMEGAGLEST_ICON_INSTALL_PATH="/usr/share/pixmaps"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS="docs/glest_factions/"
+
+ cmake-utils_src_install
+
+ prepgamesdirs
+
+}