summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-05-10 20:05:37 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-05-10 20:05:37 +0000
commit00835e8479625b1a8dec237cae4440c8e397451b (patch)
tree8237ad2bd31a2bab8fd88941fc64b9573949693c /games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
parentBumping to 1.0 and removing old version (diff)
downloadgentoo-2-00835e8479625b1a8dec237cae4440c8e397451b.tar.gz
gentoo-2-00835e8479625b1a8dec237cae4440c8e397451b.tar.bz2
gentoo-2-00835e8479625b1a8dec237cae4440c8e397451b.zip
initital import wrt #171475
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild')
-rw-r--r--games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
new file mode 100644
index 000000000000..7c2ce3f95a88
--- /dev/null
+++ b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild,v 1.1 2012/05/10 20:05:37 hasufell Exp $
+
+EAPI=3
+
+inherit eutils games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://tron.homeunix.org/ja2/editor.slf.gz"
+
+LICENSE="SFI-SCLA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall editor zlib"
+
+RDEPEND="media-libs/libsdl[X,audio,video]
+ cdinstall? ( games-strategy/ja2-stracciatella-data )
+ zlib? ( sys-libs/zlib )"
+
+LANGS="en de fr it nl pl ru ru_gold"
+for l in ${LANGS}; do
+ IUSE="$IUSE linguas_${l}"
+done
+unset l
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ sed \
+ -e "s:/some/place/where/the/data/is:${GAMES_DATADIR}/ja2:" \
+ -i sgp/FileMan.cc || die
+
+ sed \
+ -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}/ja2/data:" \
+ "${FILESDIR}"/ja2-convert.sh > "${T}"/ja2-convert || die
+}
+
+src_compile() {
+ local myconf i
+
+ for i in ${LANGS} ; do
+ if has ${i} ${LINGUAS} ; then
+ case ${i} in
+ de) myconf="LNG=GERMAN" ;;
+ nl) myconf="LNG=DUTCH" ;;
+ fr) myconf="LNG=FRENCH" ;;
+ it) myconf="LNG=ITALIAN" ;;
+ pl) myconf="LNG=POLISH" ;;
+ ru) myconf="LNG=RUSSIAN" ;;
+ ru_gold) myconf="LNG=RUSSIAN_GOLD" ;;
+ en) myconf="LNG=ENGLISH" ;;
+ *) die "wat" ;;
+ esac
+ break
+ fi
+ done
+ elog "Chosen language is ${myconf#LNG=}"
+
+ use editor && myconf+=" JA2EDITOR=yes JA2BETAVERSION=yes"
+ use zlib && myconf+=" WITH_ZLIB=yes"
+
+ emake ${myconf} || die
+}
+
+src_install() {
+ dogamesbin ja2 "${T}"/ja2-convert || die
+
+ if use editor; then
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins "${WORKDIR}"/editor.slf || die
+ fi
+
+ make_desktop_entry ja2 ${PN}
+ doman ja2.6
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "You need ja2 in the chosen language, otherwise set it in package.use!"
+
+ if ! use cdinstall ; then
+ elog "You need to copy all files from the Data directory of"
+ elog "Jagged Alliance 2 installation to"
+ elog "${GAMES_DATADIR}/ja2/data "
+ elog "Make sure the filenames are lowercase. You may want to run the"
+ elog "script":
+ elog "${GAMES_BINDIR}/ja2-convert"
+ fi
+}