summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-25 23:59:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-25 23:59:18 +0000
commitef2a5981c0ccb66a6f673f44dc90c4efb4644885 (patch)
tree5691b58fb8237a7fe5a73ef555bb5097f3ddbbf9 /games-strategy/freelords
parentBump to 0.1.12, fixes #236974 (diff)
downloadgentoo-2-ef2a5981c0ccb66a6f673f44dc90c4efb4644885.tar.gz
gentoo-2-ef2a5981c0ccb66a6f673f44dc90c4efb4644885.tar.bz2
gentoo-2-ef2a5981c0ccb66a6f673f44dc90c4efb4644885.zip
gcc43 patch from Petr Behan (bug #267204); tidy
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy/freelords')
-rw-r--r--games-strategy/freelords/ChangeLog6
-rw-r--r--games-strategy/freelords/files/freelords-0.3.8-gcc43.patch87
-rw-r--r--games-strategy/freelords/freelords-0.3.8.ebuild15
3 files changed, 98 insertions, 10 deletions
diff --git a/games-strategy/freelords/ChangeLog b/games-strategy/freelords/ChangeLog
index 5802b5b180d7..71b6e8853b69 100644
--- a/games-strategy/freelords/ChangeLog
+++ b/games-strategy/freelords/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/freelords
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.31 2009/01/17 14:34:45 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.32 2009/04/25 23:59:18 mr_bones_ Exp $
+
+ 25 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/freelords-0.3.8-gcc43.patch, freelords-0.3.8.ebuild:
+ gcc43 patch from Petr Behan (bug #267204); tidy
17 Jan 2009; nixnut <nixnut@gentoo.org> freelords-0.3.8.ebuild:
ppc stable #253621
diff --git a/games-strategy/freelords/files/freelords-0.3.8-gcc43.patch b/games-strategy/freelords/files/freelords-0.3.8-gcc43.patch
new file mode 100644
index 000000000000..23af78ac496b
--- /dev/null
+++ b/games-strategy/freelords/files/freelords-0.3.8-gcc43.patch
@@ -0,0 +1,87 @@
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/ArmyInfo.h xlords/src/ArmyInfo.h
+--- freelords-0.3.8/work/freelords-0.3.8/src/ArmyInfo.h 2007-05-02 23:40:55.000000000 +0200
++++ xlords/src/ArmyInfo.h 2009-04-23 14:16:51.000000000 +0200
+@@ -55,6 +55,8 @@
+ */
+ static void setPressable(ArmyInfo* armyinfo, bool pressable = true)
+ {armyinfo->d_pressable = pressable;}
++ static void enablePressable(ArmyInfo* armyinfo)
++ {setPressable(armyinfo, true);}
+
+ private:
+ // EVENT HANDLER
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/Threatlist.cpp xlords/src/Threatlist.cpp
+--- freelords-0.3.8/work/freelords-0.3.8/src/Threatlist.cpp 2007-05-02 23:40:55.000000000 +0200
++++ xlords/src/Threatlist.cpp 2009-04-23 14:07:04.000000000 +0200
+@@ -12,6 +12,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <algorithm>
+ #include <iostream>
+
+ #include "Threatlist.h"
+@@ -226,7 +227,7 @@
+
+ bool Threatlist::flRemove(Threat* object)
+ {
+- iterator threatit = find(begin(), end(), object);
++ iterator threatit = std::find(begin(), end(), object);
+ if (threatit != end())
+ {
+ delete object;
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/stackinfo.cpp xlords/src/stackinfo.cpp
+--- freelords-0.3.8/work/freelords-0.3.8/src/stackinfo.cpp 2007-05-02 23:40:56.000000000 +0200
++++ xlords/src/stackinfo.cpp 2009-04-23 14:16:53.000000000 +0200
+@@ -71,7 +71,7 @@
+ if (selected == 1) ArmyInfo::setPressable(d_armyinfovector[last_selected_army], false);
+ else
+ {
+- for_each(d_armyinfovector.begin(), d_armyinfovector.end(), ArmyInfo::setPressable);
++ std::for_each(d_armyinfovector.begin(), d_armyinfovector.end(), ArmyInfo::enablePressable);
+ }
+ }
+
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/stacklist.cpp xlords/src/stacklist.cpp
+--- freelords-0.3.8/work/freelords-0.3.8/src/stacklist.cpp 2007-05-02 23:40:56.000000000 +0200
++++ xlords/src/stacklist.cpp 2009-04-23 14:06:30.000000000 +0200
+@@ -12,6 +12,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <algorithm>
++
+ #include "stacklist.h"
+ #include "stack.h"
+ #include "path.h"
+@@ -333,7 +335,7 @@
+ bool Stacklist::flRemove(Stack* object)
+ {
+ debug("removing stack with id " << object->getId() << endl);
+- iterator stackit = find(begin(), end(), object);
++ iterator stackit = std::find(begin(), end(), object);
+ if (stackit != end())
+ {
+ if (d_activestack == object)
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/stacklist.h xlords/src/stacklist.h
+--- freelords-0.3.8/work/freelords-0.3.8/src/stacklist.h 2007-05-02 23:40:56.000000000 +0200
++++ xlords/src/stacklist.h 2009-04-23 14:05:44.000000000 +0200
+@@ -15,6 +15,7 @@
+ #ifndef STACKLIST_H
+ #define STACKLIST_H
+
++#include <string>
+ #include <list>
+ #include <pgmessageobject.h>
+ #include <sigc++/object_slot.h>
+diff -ur freelords-0.3.8/work/freelords-0.3.8/src/utils/extractv.cpp xlords/src/utils/extractv.cpp
+--- freelords-0.3.8/work/freelords-0.3.8/src/utils/extractv.cpp 2007-05-02 23:41:02.000000000 +0200
++++ xlords/src/utils/extractv.cpp 2009-04-23 14:18:26.000000000 +0200
+@@ -15,6 +15,7 @@
+ // Andrea Paternesi 17/02/2005
+
+ #include <stdio.h>
++#include <string.h>
+ #include <string>
+ #include <vector>
+ #include <iostream>
diff --git a/games-strategy/freelords/freelords-0.3.8.ebuild b/games-strategy/freelords/freelords-0.3.8.ebuild
index b7e87f228be1..fd401661c652 100644
--- a/games-strategy/freelords/freelords-0.3.8.ebuild
+++ b/games-strategy/freelords/freelords-0.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.8.ebuild,v 1.6 2009/01/17 14:34:45 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.8.ebuild,v 1.7 2009/04/25 23:59:18 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -20,15 +20,13 @@ RDEPEND="dev-libs/expat
media-libs/sdl-image
>=media-libs/freetype-2
>=media-libs/paragui-1.1.8
- =dev-libs/libsigc++-1.2*
+ dev-libs/libsigc++:1.2
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e '/locale/s:$(datadir):/usr/share:' \
-e '/locale/s:$(prefix):/usr:' \
@@ -36,16 +34,15 @@ src_unpack() {
-e '/freelords.desktop/d' \
$(find -name 'Makefile.in*') \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
-src_compile() {
+src_configure() {
egamesconf \
--disable-dependency-tracking \
--disable-paraguitest \
$(use_enable editor) \
- $(use_enable nls) \
- || die
- emake || die "emake failed"
+ $(use_enable nls)
}
src_install() {