summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-10 11:40:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-10 11:40:28 +0000
commit1acaf45d4d0988cf079d5bbfceeb4d25f7b5fbe2 (patch)
tree937037b9dc07c16d9684b2f783a8a017c5926839 /games-strategy/crimson/crimson-0.4.2.ebuild
parentClosing #49598 + springcleaning. (Manifest recommit) (diff)
downloadgentoo-2-1acaf45d4d0988cf079d5bbfceeb4d25f7b5fbe2.tar.gz
gentoo-2-1acaf45d4d0988cf079d5bbfceeb4d25f7b5fbe2.tar.bz2
gentoo-2-1acaf45d4d0988cf079d5bbfceeb4d25f7b5fbe2.zip
version bump
Diffstat (limited to 'games-strategy/crimson/crimson-0.4.2.ebuild')
-rw-r--r--games-strategy/crimson/crimson-0.4.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-strategy/crimson/crimson-0.4.2.ebuild b/games-strategy/crimson/crimson-0.4.2.ebuild
new file mode 100644
index 000000000000..281d9987ebad
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.4.2.ebuild,v 1.1 2004/05/10 11:40:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="zlib"
+
+DEPEND=">=media-libs/libsdl-1.1.5
+ >=media-libs/sdl-mixer-1.2.4
+ media-libs/sdl-ttf
+ dev-libs/libxslt
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable zlib) \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README* THANKS TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+ echo
+ einfo "If you have older save files and you wish to continue those games,"
+ einfo "you'll need to remerge the version with which you started"
+ einfo "those save-games."
+}