summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 08:29:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 08:29:29 +0000
commit51088973409e749e48af2631b578b8fbf485637f (patch)
treefb37251b21114e2a8130d652f3c6524f2eb7d71f /games-simulation/senken/senken-0.3.0.ebuild
parentMarked ppc (diff)
downloadgentoo-2-51088973409e749e48af2631b578b8fbf485637f.tar.gz
gentoo-2-51088973409e749e48af2631b578b8fbf485637f.tar.bz2
gentoo-2-51088973409e749e48af2631b578b8fbf485637f.zip
fix deps for bug #64599; tidy
Diffstat (limited to 'games-simulation/senken/senken-0.3.0.ebuild')
-rw-r--r--games-simulation/senken/senken-0.3.0.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/games-simulation/senken/senken-0.3.0.ebuild b/games-simulation/senken/senken-0.3.0.ebuild
index 4eaa593f0476..115dba3d086b 100644
--- a/games-simulation/senken/senken-0.3.0.ebuild
+++ b/games-simulation/senken/senken-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.2 2004/06/24 23:23:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.3 2004/09/19 08:29:29 mr_bones_ Exp $
inherit games
@@ -14,7 +14,7 @@ KEYWORDS="x86"
IUSE="nls"
RDEPEND="virtual/x11
- =x11-libs/gtk+-1*
+ >=x11-libs/gtk+-2
>=media-libs/libsdl-1.2.4
media-libs/sdl-image"
DEPEND="${RDEPEND}
@@ -22,14 +22,15 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S} && \
+ cd "${S}"
sed -i \
-e "s:/usr/local/share:${GAMES_DATADIR}:" \
- lib/utils.h || die "sed lib/utils.h failed"
+ lib/utils.h \
+ || die "sed lib/utils.h failed"
}
src_compile() {
- egamesconf `use_enable nls` || die
+ egamesconf $(use_enable nls) || die
emake || die "emake failed"
}
@@ -38,12 +39,12 @@ src_install() {
dodoc AUTHORS README TODO
dodir "${GAMES_DATADIR}"
- cd "${D}/${GAMES_PREFIX}"
- mv share/senken "${D}/${GAMES_DATADIR}/"
- rm -rf include lib man share
+ mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" \
+ || die "mv failed"
+ rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share}
- insinto ${GAMES_DATADIR}/senken/img
- doins ${S}/img/*.png
+ insinto "${GAMES_DATADIR}/senken/img"
+ doins img/*.png
find "${D}/${GAMES_DATADIR}/" -type f -exec chmod a-x \{\} \;
find "${D}/${GAMES_DATADIR}/" -name "Makefile.*" -exec rm -f \{\} \;