summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-04-12 11:48:28 +0000
committerDavid Holm <dholm@gentoo.org>2005-04-12 11:48:28 +0000
commitf1bfbaba1ea12258208e9971c959e3042d8b0a67 (patch)
tree9bdc7798cf3eec7c01fda945abbeab0fd23f6ac6 /games-simulation/openttd
parentupdate metadata (diff)
downloadgentoo-2-f1bfbaba1ea12258208e9971c959e3042d8b0a67.tar.gz
gentoo-2-f1bfbaba1ea12258208e9971c959e3042d8b0a67.tar.bz2
gentoo-2-f1bfbaba1ea12258208e9971c959e3042d8b0a67.zip
Added modifications as recommended by Bug #79969
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/Manifest4
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.3.6-r11
-rw-r--r--games-simulation/openttd/openttd-0.3.6-r1.ebuild130
4 files changed, 141 insertions, 2 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index c34fec456f35..793427dbbe7d 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.11 2005/02/20 13:16:22 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.12 2005/04/12 11:48:28 dholm Exp $
+
+*openttd-0.3.6-r1 (12 Apr 2005)
+
+ 12 Apr 2005; David Holm <dholm@gentoo.org> +openttd-0.3.6-r1.ebuild:
+ Added ebuild changes as suggested by Anton Romanov <theli (at) ukr (dot)
+ net> (Bug #79969)
20 Feb 2005; David Holm <dholm@gentoo.org> openttd-0.3.6.ebuild:
Stable on ppc
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index 1e77bd81b92a..7a7ae92286e3 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,7 +1,9 @@
-MD5 cbda9fa306888900535ca7a2babfeb8f ChangeLog 1926
+MD5 f5da7071d0b6584a21af364756cd7b8a ChangeLog 2126
MD5 7efefbbe81a05cbc5d4e96203f047fda metadata.xml 245
MD5 f4ede9d0e41a8386a7ed0707ba228c4b openttd-0.3.5.ebuild 2248
MD5 68f4e8df406ce786237ff3fec15d3315 openttd-0.3.6.ebuild 3313
+MD5 e7b6c49405e72b6ebdae7b1743bec0de openttd-0.3.6-r1.ebuild 4174
MD5 94e0df18e09dc754083d5e1247f809b7 files/digest-openttd-0.3.5 73
MD5 a169eb5c8572ee01be52c4accf2608a2 files/openttd.initd 529
MD5 2c2239b2fd69956b2e3027818efc62e5 files/digest-openttd-0.3.6 66
+MD5 706c1f4a051e6472683d79b75f3def11 files/digest-openttd-0.3.6-r1 73
diff --git a/games-simulation/openttd/files/digest-openttd-0.3.6-r1 b/games-simulation/openttd/files/digest-openttd-0.3.6-r1
new file mode 100644
index 000000000000..b085a60d8f7d
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-0.3.6-r1
@@ -0,0 +1 @@
+MD5 4127f17e45c5dd2e1720ebf2a96e7eac openttd-0.3.6-source.tar.gz 2511895
diff --git a/games-simulation/openttd/openttd-0.3.6-r1.ebuild b/games-simulation/openttd/openttd-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..1b19026c0860
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.3.6-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.3.6-r1.ebuild,v 1.1 2005/04/12 11:48:28 dholm Exp $
+
+inherit eutils games
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SRC_URI="mirror://sourceforge/openttd/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug png zlib timidity alsa dedicated"
+
+DEPEND="media-libs/libsdl
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/alsa-utils ) )
+ )"
+
+src_compile() {
+ local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_NETWORK=1 INSTALL=1 RELEASE=${PV} USE_HOMEDIR=1 PERSONAL_DIR=.openttd PREFIX=/usr DATA_DIR=share/games/${PN}"
+ use debug && myopts="${myopts} DEBUG=1"
+ use dedicated && myopts="${myopts} DEDICATED=1"
+ if ! use dedicated; then
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+ myopts="${myopts} WITH_SDL=1"
+ if ! use timidity; then
+ use alsa && myopts="${myopts} MIDI=/usr/bin/pmidi"
+ fi
+ fi
+
+ emake -j1 ${myopts} || die "emake failed"
+}
+
+src_install() {
+ dogamesbin openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed (data)"
+
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed (lang)"
+
+ insinto "${GAMES_DATADIR}/${PN}/scenario"
+ doins scenario/* || die "doins failed (scenario)"
+
+ insinto "${GAMES_DATADIR}/${PN}/scripts"
+ doins scripts/* || die "doins failed (scripts)"
+
+ doicon media/openttd.*.png
+
+ if ! use dedicated; then
+ if use timidity || use alsa; then
+ make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd.64.png
+ else
+ make_desktop_entry openttd "OpenTTD" openttd.64.png
+ fi
+ else
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openttd.initd openttd
+ fi
+
+ dodoc readme.txt changelog.txt docs/Manual.txt docs/console.txt \
+ docs/multiplayer.txt
+ doman docs/openttd.6
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ echo
+ einfo "From the WINDOWS version you need: "
+ einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo "OR from the DOS version you need: "
+ einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ echo
+ einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
+ einfo "you will have to symlink them to ~/.openttd/scenario in order"
+ einfo "to use them."
+ einfo "Example:"
+ einfo " mkdir -p ~/.openttd/scenario"
+ einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+ echo
+ einfo "File names are case sensitive so make sure they are "
+ einfo "correct for whichever version you have."
+ echo
+
+ if use dedicated; then
+ einfo "You have chosen the dedicated USE flag which builds a "
+ einfo "version of OpenTTD to be used as a game server which "
+ einfo "does not require SDL. You will not be able to play the "
+ einfo "game, but if you don't pass this flag you can still use "
+ einfo "it as a server in the same way, but SDL will be required."
+ echo
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ echo
+ else
+ if use timidity || use alsa; then
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ einfo "You can enable MIDI by running:"
+ einfo " openttd -m extmidi"
+ echo
+ if use timidity; then
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "You have emerged with 'aplaymidi' for playing MIDI."
+ einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ einfo "Available ports can be listed by using 'aplaymidi -l'."
+ fi
+ else
+ einfo "timidity and/or alsa not in USE so music will not be played during the game."
+ fi
+ echo
+ fi
+}